View Revisions: Issue #7324

Summary 0007324: IDLE_3.9.2-3 doesn't support new Python3.9.7 so; idle_3.9.2-3 and python3-tk(3.9.2-3) should be upgraded to support python3.9.7
Revision 2021-09-13 21:10 by g0tmi1k
Description After upgrading python3.9.2-3 to python3.9.7; idle-3.9.2-3 doesn't run then it shows error as

"ImportError: cannot import name '_setup_dialog' from 'tkinter.simpledialog' (/usr/lib/python3.9/tkinter/simpledialog.py)"

and I investigated the detail ,it's depends on python3-tk (3.9.7-2) but in Kali repository there is only python3-tk (3.9.2-3) available. But in the original tkinter repo there is python3-tk (3.9.7-2) already available.

Hope issue will be solved soon.
Thank you.
Humm Doc
Revision 2021-09-10 11:15 by hummAPT0
Description After upgrading python3.9.2-3 to python3.9.7; idle-3.9.2-3 doesn't run then it shows error as

"ImportError: cannot import name '_setup_dialog' from 'tkinter.simpledialog' (/usr/lib/python3.9/tkinter/simpledialog.py)"

and I investigated the detail ,it's depends on python3-tk (3.9.7-2) but in Kali repository there is only python3-tk (3.9.2-3) available. But in the original tkinter repo there is python3-tk (3.9.7-2) already available.

Hope issue will be solved soon.
Thank you.
Humm Doc