2018-04-27 04:38 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004558Kali Linux[All Projects] Kali Package Bugpublic2018-03-06 15:02
Reporterpadgett 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
Product Version2018.1 
Target VersionFixed in Version 
Summary0004558: Attempt to boot Kali 2018-1 or W08 fails on Apollo Lake laptop - Intel N3350/InsiteH2O bios
DescriptionHave Created a number of USB disks from Kali downloads 2018-1 and W08 amd64, regular and KDE using W32DiskImager.

Bootx64 files on USB added to UEFI store in BIOS on both

Have two Acer notebooks, R11 (R3-131T-p344) with Intel N3700 -4 core Braswell and Acer Spin1 (SP111-31N-C4UG) with Intel N3350 -2 core Apollo Lake (later version of R11)

Both able to run Windows 10-64 v1709.

R11 boots normally to menu while Spin1 hangs on initial boot following BIOS (F12) selection: light in USB on and single white dot on upper left of display. Hangs until aborted.

Steps To ReproduceCreate USB using Win32DiskImage and current KALI distribution (e.g. kali-linux-2018.1-amd64.iso).

Add BOOTX64.EFI file to trusted UEFI store in Notebook BIOS.

Attempt to boot from USB (F12) and hangs on current model Acer Spin 1 (Apollo Lake). Works on older model R11 (Braswell)
Additional InformationThis is true of a number of Linux distributions including Ubuntu and Debian. Majaro 17.1.5 is the only Linux distribution that has booted properly on the Spin1.

Have seen comments on net that this may be a GRUB issue.

Attached Files

-Relationships
+Relationships

-Notes

~0008805

padgett (reporter)

If any testing is needed, I have several systems including the Apollo Lake Spin 1. However cannot post on the forum since activation e-mail was not received but can send/receive PMs.

~0008807

padgett (reporter)

Sunday Feb 25. Downloaded the weekly 2018-W09 update. Now can boot Spin 1 - UEFI gets initial menu after adding Bootx64.efi to store. (09-2.jpg) but fails when a different file is loaded.

Erased UEFI store in BIOS and Kali was able to be selected and load properly (live).

W09 has most of the answer but still requires turning UEFI off by erasing the store.

BTW still am not allowed to post to the forum.

~0008816

padgett (reporter)

I see nothing in the change log or release notes to explain why w09 now boots on an Apollo Lake notebook(though have to turn UEFI off - see 09-1.jpg). Does anyone know what changed in the boot process ? (Still cannot post to forum).

~0008818

rhertzog (administrator)

We did not change anything significant at the Kali level. It might be that something changed in Debian Testing.

We did however upgrade Linux from 4.14.13 to 4.14.17:
https://pkg.kali.org/pkg/linux

(I can't help you with the forum)

~0008819

padgett (reporter)

Thank you. From the way it was acting I suspect an issue with the BOOTX64.EFI, the w09 is significantly different than w08.

Can boot now but not using UEFI, have to change to legacy.

~0008820

rhertzog (administrator)

I think you are mixing UEFI and Secure Boot. The fact that you have to turn "Secure boot" off is expected and normal as we are not providing binaries vetted by Microsoft.

But your 09-1.jpg is still an UEFI boot menu as it's based on grub and not on syslinux (which we use for BIOS boot).

~0008824

padgett (reporter)

Not confusing, could add the BOOTX64.EFI to the UEFI library and that part booted properly. It was a secondary file that I cannot add to the store that failed (see 09-1.jpg).

With MANJARO (Arch based) all I need to do is to add the BOOTX64 file to the store and the boot proceeds normally even with Secure Boot turned on. So current libraries can add signatures

Tried many distros before posting. Will admit to being somewhat out of date on Linux but started with UNIX a few generations ago and remember when the "free" version of Red Hat became Fedora. Before retirement I used Kali quite a bit to analyze large systems and like its power - why I've spent so much time with it.

Thank you for responding.

~0008874

padgett (reporter)

6Mar18: W10 is acting like W09 if bootx64.efi is added to the UEFI store it boots to menu but gives an error as in jpg 09-1. Turning secure boot off by erasing the store in BIOS>Security allows a full live boot.

Saw the note about Kali being in the Windows store - does this mean there is a version signed by Microsoft and can boot with UEFI turned on ? If so can the live version be downloaded from the store ?

~0008875

muts (administrator)

Kali in the windows store is based on WSL, you dont boot from it.
+Notes

-Issue History
Date Modified Username Field Change
2018-02-24 00:43 padgett New Issue
2018-02-24 16:06 padgett Note Added: 0008805
2018-02-24 16:12 padgett File Added: boothang.jpg
2018-02-25 14:48 padgett File Added: 09-2.jpg
2018-02-25 14:49 padgett File Added: 09-1.jpg
2018-02-25 14:55 padgett Note Added: 0008807
2018-02-26 16:40 padgett Note Added: 0008816
2018-02-26 20:51 rhertzog Note Added: 0008818
2018-02-26 23:02 padgett Note Added: 0008819
2018-02-27 07:52 rhertzog Note Added: 0008820
2018-02-27 14:37 padgett Note Added: 0008824
2018-03-06 14:58 padgett Note Added: 0008874
2018-03-06 15:02 muts Note Added: 0008875
+Issue History