View Issue Details

IDProjectCategoryView StatusLast Update
0005141Kali Linux[All Projects] Kali Package Bugpublic2019-02-10 16:54
ReporterpkreuztAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.4 
Target VersionFixed in Version2019.2 
Summary0005141: latest kernel (4.18.0-kali3) fails to boot
DescriptionHaving updated to this kernel, my laptop no longer boots and shows only black screen after grub menu and before LUKS password prompt. Selecting kernel 4.18.0-kali2 in grub, it boots fine. On another machine with dual boot and other distro's grub it also boots correctly with 4.18.0-kali3 kernel.


has duplicate 0005169 closedsbrun kali3 kernel 
has duplicate 0005163 closedsbrun black screen after full-upgrade 



2018-12-05 14:00

manager   ~0010075

Can you provide more details, like architecture, grub version, is it in a virtual machine (which one..) ?


2018-12-05 14:43

reporter   ~0010077

Both machines are physical and x86_64. Laptop (the one which fails) uses kali's grub-efi 2.02+dfsg1-8kali1 and the other PC (dual boot) uses Mageia's grub2-efi 2.02.0-1.1 with custom.conf entry (not autodetected) copied directly from kali's grub config.


2018-12-06 14:36

reporter   ~0010084

Don't know if this helps, but switching to recovery mode I see some messages on the console before the hang. Last messages refer to detection of integrated graphics card (it's an Optimus laptop):

[ 2.792354] pci 0000:00:00:.0: Intel HD Graphics Chipset
[ 2.794245] pci 0000:00:00:.0: detected gtt size: 2097152K total, 262144K mappable
[ 2.796534] pci 0000:00:00:.0: detected 32768K stolen memory
[ 2.798105] fb: switching to inteldrmfb from EFI VGA

and the boot stops there.


2018-12-08 09:33

reporter   ~0010096

I have the same problem, after upgrade latest kernel 4.18.0-kali3... after reboot i have a black screen (even the cursor is not blinking.) Laptop TOSHIBA Satellite Pro L300, 4.18.0-kali2-amd64 x86_64, grub 2.02+dfsg1-8kali1.


2018-12-09 09:59

reporter   ~0010098

Sorry for my English. I have the same problem:

Try to install: Kali Linux Light 64 Bit, Kali Linux KDE 64 Bit, Kali Linux XFCE 64 Bit, all version 2018.4

System: Lenovo X201 i5 450m 8GB Ram

Step 1: Install Kali on ssd 160GB with LUKS and let 20GB Free. That works fine. Finish installation and reboot.

Step 2: apt update && apt dist-upgrade -y && apt autoremove -y && reboot

Step 3: Boot-loader OK LUKS OK. After typing the LUKSPASS it shows only a "Black" i think it show the grey background from the GNOME login screen (same colors) But i don't install GNOME. ctrl alt del don't work HDD activity after pressing this but no effect...


2018-12-21 05:57

reporter   ~0010126

as i can see kali3 does not support intel hd graphic , same here , u can press "e" at grub - at linux line go to last part (after quiet) and type 'i915.modeset=0'(if this didnt worked then type nomodeset) and control+x in way u will be able to use kali3 (startx) , i think if u have intel graphic driver u can install it and maybe u can boot up!( i dont know this works or not)


2019-02-08 14:27

administrator   ~0010271

Does the problem persist with the current 4.19 kernel?


2019-02-09 19:06

reporter   ~0010276

No, with 4.19 kernel it boots fine.


2019-02-10 16:54

administrator   ~0010278

Thanks, closing the ticket.

Issue History

Date Modified Username Field Change
2018-12-05 13:22 pkreuzt New Issue
2018-12-05 14:00 sbrun Assigned To => sbrun
2018-12-05 14:00 sbrun Status new => feedback
2018-12-05 14:00 sbrun Note Added: 0010075
2018-12-05 14:43 pkreuzt Note Added: 0010077
2018-12-05 14:43 pkreuzt Status feedback => assigned
2018-12-06 14:36 pkreuzt Note Added: 0010084
2018-12-08 09:33 m1r Note Added: 0010096
2018-12-09 09:59 NeroSec Note Added: 0010098
2018-12-20 08:58 sbrun Relationship added has duplicate 0005169
2018-12-20 08:59 sbrun Relationship added has duplicate 0005163
2018-12-21 05:57 Arthas Note Added: 0010126
2019-02-08 14:27 rhertzog Status assigned => feedback
2019-02-08 14:27 rhertzog Note Added: 0010271
2019-02-09 19:06 pkreuzt Note Added: 0010276
2019-02-09 19:06 pkreuzt Status feedback => assigned
2019-02-10 16:54 rhertzog Status assigned => resolved
2019-02-10 16:54 rhertzog Resolution open => fixed
2019-02-10 16:54 rhertzog Fixed in Version => 2019.2
2019-02-10 16:54 rhertzog Note Added: 0010278