View Issue Details

IDProjectCategoryView StatusLast Update
0005194Kali Linux[All Projects] General Bugpublic2019-01-17 23:40
ReporterintosecAssigned Torhertzog 
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2019.1 
Summary0005194: System failed to boot after upgrading udev
DescriptionI'm using a Kali linux 2018.4 in VMware workstation 15, after I upgrade udev and reboot the system, it stuck in initramfs and shows "/dev/sda1 does not exist".
I tried to fix this problem with kinds of methods, but it didn't work.
Then, I recovered the snapshot, but after I upgrade udev, the error happened again.
So I download another cdimage from [http://cdimage.kali.org/kali-images/kali-weekly/kali-linux-xfce-2019-W02-amd64.iso] which just released a few minutes ago, and create another vm. After the installation and auto rebooting, it stuck in initramfs just the same.
Steps To Reproducejust run "apt update && apt install udev -y && reboot"

Activities

intosec

2019-01-06 07:10

reporter  

1.png (6,162 bytes)
1.png (6,162 bytes)

intosec

2019-01-06 07:14

reporter  

2.png (17,104 bytes)
2.png (17,104 bytes)

intosec

2019-01-06 07:23

reporter   ~0010167

kali-linux-xfce-2019-W02-amd64.iso Live System has the same issue

3.png (11,886 bytes)
3.png (11,886 bytes)

JGJones

2019-01-10 12:05

reporter   ~0010188

Created a new VM in VMware Workstation Pro 14.

Used the kali-linux-light-2019-W02-amd64.iso from weekly download

Used default settings when installing and after reboot, it fails with the sda1 not found (same as in note 0000001)

No apt upgrade was used in this case.

kalibug.png (8,946 bytes)
kalibug.png (8,946 bytes)

rhertzog

2019-01-10 15:00

administrator   ~0010192

So this is really an issue in udev. We have imported the latest version (240-3) in Kali today. Can you check if that new version fixes the issue for you?

You might want to try with the daily image of tomorrow (today's version doesn't have it yet):
https://archive.kali.org/kali-daily-images/

rhertzog

2019-01-10 15:17

administrator   ~0010193

From the last discussion at the upstream level, it might be that 240-3 is not sufficient to solve this issue. See https://github.com/systemd/systemd/issues/11314 but it's still useful data to have.

rhertzog

2019-01-10 15:26

administrator   ~0010194

Other relevant bug report on the Debian side: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917607

JGJones

2019-01-10 17:22

reporter   ~0010196

Snapshotted a fresh 2018.4 install and then did an `apt update && apt install systemd udev -y` and rebooted. systemd is the latest 240-3 version.

Still an issue but as you pointed out, 240-3 isn't sufficient.

(was going to report in here that it's not unique to Kali as just had the same issue with ParrotOS (also Debian based like Kali).

rhertzog

2019-01-11 08:35

administrator   ~0010198

There's a patch fixing the issue in the upstream ticket: https://github.com/systemd/systemd/pull/11389
(the first commit of that pull request seems to be enough). Hopefully a final fix will shortly flow into Debian unstable and I'll merge it ASAP.

rhertzog

2019-01-14 09:37

administrator   ~0010203

I have imported udev 240-4 from Debian unstable. It should fix this issue.

JGJones

2019-01-14 12:11

reporter   ~0010205

Will test - is it in daily ISO? It's not in the repo's yet (240-3 is the latest at present)

rhertzog

2019-01-14 13:05

administrator   ~0010206

It's not yet in the daily ISO. It will be there tomorrow (January 15th). It should be on the mirrors since a few minutes ago.

JGJones

2019-01-14 13:19

reporter   ~0010207

OK it's now in the repo as you confirmed and I've updated to version 240-4. I can now boot up successfully :)

rhertzog

2019-01-15 10:12

administrator   ~0010210

Thanks for the confirmation, closing ticket.

Issue History

Date Modified Username Field Change
2019-01-06 07:10 intosec New Issue
2019-01-06 07:10 intosec File Added: 1.png
2019-01-06 07:14 intosec File Added: 2.png
2019-01-06 07:23 intosec File Added: 3.png
2019-01-06 07:23 intosec Note Added: 0010167
2019-01-10 12:05 JGJones File Added: kalibug.png
2019-01-10 12:05 JGJones Note Added: 0010188
2019-01-10 15:00 rhertzog Note Added: 0010192
2019-01-10 15:00 rhertzog Assigned To => rhertzog
2019-01-10 15:00 rhertzog Status new => assigned
2019-01-10 15:17 rhertzog Status assigned => feedback
2019-01-10 15:17 rhertzog Note Added: 0010193
2019-01-10 15:26 rhertzog Note Added: 0010194
2019-01-10 17:22 JGJones Note Added: 0010196
2019-01-11 08:35 rhertzog Note Added: 0010198
2019-01-11 08:36 rhertzog Status feedback => assigned
2019-01-14 09:37 rhertzog Note Added: 0010203
2019-01-14 12:11 JGJones Note Added: 0010205
2019-01-14 13:05 rhertzog Note Added: 0010206
2019-01-14 13:19 JGJones Note Added: 0010207
2019-01-15 10:12 rhertzog Status assigned => resolved
2019-01-15 10:12 rhertzog Resolution open => fixed
2019-01-15 10:12 rhertzog Fixed in Version => 2019.1
2019-01-15 10:12 rhertzog Note Added: 0010210