View Issue Details

IDProjectCategoryView StatusLast Update
0005554Kali Linux[All Projects] Kali Package Bugpublic2019-06-20 08:13
ReporterJohnWasser Assigned Tog0tmi1k  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005554: apt-get upgrade gets 404 errors on four packages
DescriptionThe packages apt, apt-utils, libapt-pkg5.0, and libapt-inst2.0 are in the Kali-Rolling amd64 repository only as version 1.8.0 and 1.8.2. The Kali-Rolling repository currently says that the latest version of those four packages is 1.8.1 so when it goes to fetch the packages for upgrade it gets a 404 Not Found error.

I think the repository listing is dated May 8th, 2019 but the 1.8.2 version was added May 31st, 2019.
Steps To ReproduceOn 2019.2:

apt-get update && apt-get upgrade --fix-missing
Additional InformationErr:1 http://http.kali.org/kali kali-rolling/main amd64 libapt-pkg5.0 amd64 1.8.1
  404 Not Found [IP: 192.99.200.113 80]
Err:2 http://http.kali.org/kali kali-rolling/main amd64 libapt-inst2.0 amd64 1.8.1
  404 Not Found [IP: 192.99.200.113 80]
Err:3 http://http.kali.org/kali kali-rolling/main amd64 apt amd64 1.8.1
  404 Not Found [IP: 192.99.200.113 80]
Err:4 http://http.kali.org/kali kali-rolling/main amd64 apt-utils amd64 1.8.1
  404 Not Found [IP: 192.99.200.113 80]

Activities

rhertzog

2019-06-18 21:54

administrator   ~0010705

Did you run "apt update" before and can you please copy/paste the log of apt update? I want to know to which mirror you are being redirected as the mirror is likely serving you an old repository listing as you say.

Otherwise please share the output of "curl -sI http://http.kali.org/README" it should indicate your mirror as well.

JohnWasser

2019-06-20 00:42

reporter   ~0010711

root@kali:~# apt update
Hit:1 http://archive.linux.duke.edu/kalilinux/kali kali-rolling InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
root@kali:~#

Looks like duke.edu is my local mirror and they updated so that 'apt' points to a valid version (1.8.2). There were 239 other packages that needed upgrades and they all worked. You can close this report as solved.

rhertzog

2019-06-20 08:13

administrator   ~0010712

Thanks, closing.

Issue History

Date Modified Username Field Change
2019-06-18 17:37 JohnWasser New Issue
2019-06-18 21:54 rhertzog Assigned To => rhertzog
2019-06-18 21:54 rhertzog Status new => feedback
2019-06-18 21:54 rhertzog Note Added: 0010705
2019-06-19 06:33 rhertzog Assigned To rhertzog => g0tmi1k
2019-06-20 00:42 JohnWasser Note Added: 0010711
2019-06-20 00:42 JohnWasser Status feedback => assigned
2019-06-20 08:13 rhertzog Status assigned => resolved
2019-06-20 08:13 rhertzog Resolution open => fixed
2019-06-20 08:13 rhertzog Note Added: 0010712