View Issue Details

IDProjectCategoryView StatusLast Update
0005845Kali Linux[All Projects] General Bugpublic2019-11-29 17:32
Reporterjjdiff Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version2019.4 
Target VersionFixed in Version 
Summary0005845: users-admin constantly crashing
DescriptionAfter installing gnome-system-tools to graphically add new users to the new Xfce environment, users-admin or Users and Groups as its graphically know opens and freezes.
The window cannot be moved, minimised, expanded or closes. To close the window in Terminal you run 'killall users-admin'.

I have restarted the machine several times, updates && upgraded the system and the specific gnome-system-tools application.
Steps To Reproduceinstall gnome-system-tools
open 'Users and Groups'

Activities

jjdiff

2019-11-29 12:19

reporter  

Screenshot 2019-11-29 at 12.18.37.png (338,083 bytes)

rhertzog

2019-11-29 14:36

administrator   ~0011485

The upstream mailing list is dead since 2011: https://mail.gnome.org/archives/system-tools-list/
No new upstream releases happened since 2011 too. The code never migrated from CVS to SVN to GIT. There's no repository for that project in gitlab.gnome.org.

In other words, this project looks dead: http://www.gnome.org/projects/gst/

I doubt that we will fix it by ourselves.

jjdiff

2019-11-29 14:46

reporter   ~0011486

No problem, if thats the case please could you tell me how to graphically add a user in the new Xfce session as I cannot see anything obvious? (I have added a user via terminal and the 'adduser' command however I cannot log in as them so I wanted a graphical solution.

rhertzog

2019-11-29 15:01

administrator   ~0011487

Why can't you log as the user that you created?

I'm sorry, I don't have any other graphical tool to suggest. A quick google search seems to suggest that gnome-system-tools is the usual choice for Xfce. It seems to work for a normal user but fails badly as you saw when run as root.

We have this conversation here as well: https://gitlab.com/kalilinux/packages/kali-meta/merge_requests/7

jjdiff

2019-11-29 15:05

reporter   ~0011488

I am unaware why I cant log in as that user. When I enter their credentials at the login page the screen goes black for approximately 2 seconds then I get taken back to the login page and the text I have entered is deleted. The code I used us below:

root@kali:~# adduser test
Adding user `test' ...
Adding new group `test' (1002) ...
Adding new user `test' (1002) with group `test' ...
Creating home directory `/home/test' ...
Copying files from `/etc/skel' ...
New password:
Retype new password:
passwd: password updated successfully
Changing the user information for test
Enter the new value, or press ENTER for the default
    Full Name []: Test Account
    Room Number []:
    Work Phone []:
    Home Phone []:
    Other []:
Is the information correct? [Y/n]
root@kali:~# usermod -aG sudo test

steev

2019-11-29 17:32

developer   ~0011490

I did the same useradd/usermod here and am able to log my created user in.

Issue History

Date Modified Username Field Change
2019-11-29 12:19 jjdiff New Issue
2019-11-29 12:19 jjdiff File Added: Screenshot 2019-11-29 at 12.18.37.png
2019-11-29 14:36 rhertzog Note Added: 0011485
2019-11-29 14:46 jjdiff Note Added: 0011486
2019-11-29 15:01 rhertzog Note Added: 0011487
2019-11-29 15:05 jjdiff Note Added: 0011488
2019-11-29 17:32 steev Note Added: 0011490