View Issue Details

IDProjectCategoryView StatusLast Update
0000171Kali Linux[All Projects] New Tool Requestspublic2013-04-01 18:00
ReporterGlidesAssigned Todookie 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000171: Tool Request: jd-gui
Descriptionjd-gui is a Java-Decompiler. It allows for decompiling of Java 5 and later byte code. (Something JAD is not capable of)

http://java.decompiler.free.fr/?q=jdgui
Additional InformationI think this would be a great addition to the RE tools in Kali.

I have already installed and tested it without any issues so far.

Activities

Glides

2013-03-23 18:11

reporter  

jd-gui-0.3.5.linux.i686.tar.gz (1,087,841 bytes)

Glides

2013-03-29 17:36

reporter   ~0000281

I tried looking for licensing info about this package, I was unable to find out much.

I didn't think about that when I made the tool request, and with the relationship with Debian I assume it would be best to not include the tool.

Please close at your convenience

dookie

2013-04-01 17:20

administrator   ~0000303

According to the readme file, it looks like it is okay to add:

JD-GUI is free for non-commercial use. This means that JD-GUI shall not be
included or embedded into commercial software products. Nevertheless, JD-GUI
may be freely used for personal needs in a commercial or non-commercial
environments.

dookie

2013-04-01 18:00

administrator   ~0000304

Committed in jd-gui_0.3.5-1kali0 and it will be in the repos soon.

Thanks for the suggestion.

Issue History

Date Modified Username Field Change
2013-03-23 18:11 Glides New Issue
2013-03-23 18:11 Glides File Added: jd-gui-0.3.5.linux.i686.tar.gz
2013-03-29 17:36 Glides Note Added: 0000281
2013-04-01 17:18 dookie Assigned To => dookie
2013-04-01 17:18 dookie Status new => assigned
2013-04-01 17:20 dookie Note Added: 0000303
2013-04-01 18:00 dookie Note Added: 0000304
2013-04-01 18:00 dookie Status assigned => closed
2013-04-01 18:00 dookie Resolution open => fixed