View Issue Details

IDProjectCategoryView StatusLast Update
0006384Kali Linux[All Projects] General Bugpublic2020-07-05 17:00
Reportergull1v3r Assigned Tosteev  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2020.2 
Target VersionFixed in Version2020.3 
Summary0006384: No USB Keyboard/Mouse on Rasberry Pi 3 B+
DescriptionWhen booting Rasberry Pi 3B+, the keyboard is available (Num and Caps lock), but after reaching the login screen on the GUI, there power for keyboard and mouse is gone.
Steps To ReproduceConnect keyboard to Rasberry Pi 3 B+, power Pi on, toggle caps/num lock during boot, observe loss of power to USB devices at login screen
Additional InformationI've only got a Rasberry Pi 3 B+, so I don't know if other models are impacted. This happens every time I power the Pi on, and I have tried multiple keyboards.

Activities

steev

2020-05-15 18:20

developer   ~0012783

Does it come back if you unplug the keyboard/mouse and then plug them back in?

gull1v3r

2020-05-15 18:43

reporter   ~0012786

No, it doesn't come back if I unplug and re-plug it.

steev

2020-05-15 19:26

developer   ~0012788

Which image(s) are you using?

steev

2020-05-15 20:16

developer   ~0012790

Can you ssh in to the pi (ssh kali@kali) and then run sudo apt update && sudo apt install xserver-xorg-input-libinput && sudo reboot - does that fix the issue for you?

gull1v3r

2020-05-15 21:58

reporter   ~0012792

I was using the 32-bit image. I followed the steps above and that fixed the problem.
kali-linux-2020.2-rpi3-nexmon.img

I downloaded the 64-bit image and that did not have the problem.
kali-linux-2020.2-rpi3-nexmon-64.img

It looks like it's just the 32-bit image I used that has the issue. I haven't tried the other 2 rpi images. (rpi0w or rpi)

steev

2020-05-15 22:00

developer   ~0012793

Si, I've already committed the fix to the git repo; When I reverted a pretty big change that was supposed to happen for 2020.2, I missed that it added back libinput being removed in the script (it was installed at a later point with the changes) - sorry for the inconvenience, I'll try to get a new 32bit image pushed out next week.

steev

2020-05-15 22:00

developer   ~0012794

Change is pushed to git, just need to publish new images.

Issue History

Date Modified Username Field Change
2020-05-15 16:58 gull1v3r New Issue
2020-05-15 18:20 steev Note Added: 0012783
2020-05-15 18:43 gull1v3r Note Added: 0012786
2020-05-15 19:25 steev Assigned To => steev
2020-05-15 19:25 steev Status new => assigned
2020-05-15 19:26 steev Note Added: 0012788
2020-05-15 20:16 steev Note Added: 0012790
2020-05-15 21:58 gull1v3r Note Added: 0012792
2020-05-15 22:00 steev Note Added: 0012793
2020-05-15 22:00 steev Status assigned => resolved
2020-05-15 22:00 steev Resolution open => fixed
2020-05-15 22:00 steev Fixed in Version => 2020.3
2020-05-15 22:00 steev Note Added: 0012794