View Issue Details

IDProjectCategoryView StatusLast Update
0000181Kali Linux[All Projects] Tool Upgradepublic2013-03-27 23:28
Reportervh Assigned Tocrossbower  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000181: tool upgrade: hydra 7.4.2 is available
Descriptionwww.thc.org/thc-hydra
version 7.4.2 is available since 3 months

Activities

crossbower

2013-03-27 23:28

reporter   ~0000254

I've lost a lot of time trying to understand why the package updated package (already in the repo) didn't compile.

My conclusion is (reported here since it can be useful for future packages):

dh_clean (seems to) starts before quilt patches are applied.

In this specific case the error, fixed via quilt patches, occurred in the "clean" phase, that runs before the patches are applied (a strange situation).

So i just disabled the "clean" phase, adding:
---
override_dh_auto_clean:
override_dh_clean:
---
to debian/rules, and the package now build correctly.

Issue History

Date Modified Username Field Change
2013-03-24 10:39 vh New Issue
2013-03-27 23:28 crossbower Note Added: 0000254
2013-03-27 23:28 crossbower Status new => resolved
2013-03-27 23:28 crossbower Resolution open => fixed
2013-03-27 23:28 crossbower Assigned To => crossbower