View Issue Details

IDProjectCategoryView StatusLast Update
0001876Kali Linux[All Projects] Kali Package Bugpublic2014-11-26 07:41
Reportergenius156iq Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.9 
Target VersionFixed in Version1.1.0 
Summary0001876: Following a Fresh install kali 1.0.9 I am unable to install metapackage kali-linux-forensic.
DescriptionFollowing a Fresh install kali 1.0.9 & apt-get update && apt-get upgrade I try to do the following:

root@kali:~# apt-get install kali-linux-forensic
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kali-linux-forensic : Depends: distorm3 but it is not going to be installed
E: Unable to correct problems, you have held broken packages."

I then try:

root@kali:~# apt-get install distorm3
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  dwarfdump libdistorm3-3 libyara0 python-openpyxl python-yara
  volatility-tools
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  python-distorm3 volatility
The following NEW packages will be installed:
  distorm3
0 upgraded, 1 newly installed, 2 to remove and 0 not upgraded.
Need to get 0 B/49.5 kB of archives.
After this operation, 12.6 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 313811 files and directories currently installed.)
Removing volatility ...
Removing python-distorm3 ...
Processing triggers for man-db ...
Selecting previously unselected package distorm3.
(Reading database ... 313061 files and directories currently installed.)
Unpacking distorm3 (from .../distorm3_3.3-1kali0_amd64.deb) ...
Setting up distorm3 (3.3-1kali0) ...
Processing triggers for python-support ...

followed by:
root@kali:~# apt-get install kali-linux-forensic
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kali-linux-forensic : Depends: volatility but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@kali:~# apt-get install volatility
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  python-distorm3
Suggested packages:
  lime-forensics-dkms
Recommended packages:
  volatility-profiles
The following packages will be REMOVED:
  distorm3
The following NEW packages will be installed:
  python-distorm3 volatility
0 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B/2,332 kB of archives.
After this operation, 12.6 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 313071 files and directories currently installed.)
Removing distorm3 ...
Processing triggers for python-support ...
Selecting previously unselected package python-distorm3.
(Reading database ... 313061 files and directories currently installed.)
Unpacking python-distorm3 (from .../python-distorm3_3.3-1kali2_all.deb) ...
Selecting previously unselected package volatility.
Unpacking volatility (from .../volatility_2.4-1~kali2_all.deb) ...
Processing triggers for man-db ...
Setting up python-distorm3 (3.3-1kali2) ...
Setting up volatility (2.4-1~kali2) ...

Wash Rinse Repeat..lol a cycle maybe this is due to the name of the python-distorm3 not equaling to "distorm3" which is a prerequirment of the forensic metapackage.
Steps To Reproduceroot@kali:~# apt-get install kali-linux-forensic
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kali-linux-forensic : Depends: distorm3 but it is not going to be installed
E: Unable to correct problems, you have held broken packages."

I then try:

root@kali:~# apt-get install distorm3
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  dwarfdump libdistorm3-3 libyara0 python-openpyxl python-yara
  volatility-tools
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  python-distorm3 volatility
The following NEW packages will be installed:
  distorm3
0 upgraded, 1 newly installed, 2 to remove and 0 not upgraded.
Need to get 0 B/49.5 kB of archives.
After this operation, 12.6 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 313811 files and directories currently installed.)
Removing volatility ...
Removing python-distorm3 ...
Processing triggers for man-db ...
Selecting previously unselected package distorm3.
(Reading database ... 313061 files and directories currently installed.)
Unpacking distorm3 (from .../distorm3_3.3-1kali0_amd64.deb) ...
Setting up distorm3 (3.3-1kali0) ...
Processing triggers for python-support ...

followed by:
root@kali:~# apt-get install kali-linux-forensic
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kali-linux-forensic : Depends: volatility but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@kali:~# apt-get install volatility
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  python-distorm3
Suggested packages:
  lime-forensics-dkms
Recommended packages:
  volatility-profiles
The following packages will be REMOVED:
  distorm3
The following NEW packages will be installed:
  python-distorm3 volatility
0 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B/2,332 kB of archives.
After this operation, 12.6 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 313071 files and directories currently installed.)
Removing distorm3 ...
Processing triggers for python-support ...
Selecting previously unselected package python-distorm3.
(Reading database ... 313061 files and directories currently installed.)
Unpacking python-distorm3 (from .../python-distorm3_3.3-1kali2_all.deb) ...
Selecting previously unselected package volatility.
Unpacking volatility (from .../volatility_2.4-1~kali2_all.deb) ...
Processing triggers for man-db ...
Setting up python-distorm3 (3.3-1kali2) ...
Setting up volatility (2.4-1~kali2) ...

Activities

muts

2014-11-21 16:02

administrator   ~0002704

Have you run an apt-get update first ?

genius156iq

2014-11-23 03:15

reporter   ~0002828

yes apt-get update && apt-get upgrade

rhertzog

2014-11-26 07:41

administrator   ~0002833

Sorry for this, we had prepared updated kali-linux-* meta-packages for python-distorm3 but somehow they have not been uploaded.

I uploaded them now and you will shortly have a fixed kali-linux-forensic (1.55.22).

Issue History

Date Modified Username Field Change
2014-11-21 16:00 genius156iq New Issue
2014-11-21 16:02 muts Note Added: 0002704
2014-11-21 20:03 haider Issue cloned: 0001910
2014-11-23 03:15 genius156iq Note Added: 0002828
2014-11-26 07:41 rhertzog Note Added: 0002833
2014-11-26 07:41 rhertzog Assigned To => rhertzog
2014-11-26 07:41 rhertzog Status new => resolved
2014-11-26 07:41 rhertzog Resolution open => fixed
2014-11-26 07:41 rhertzog Fixed in Version => 1.1.0