View Issue Details

IDProjectCategoryView StatusLast Update
0001942Kali Linux[All Projects] Kali Package Bugpublic2014-12-05 15:00
Reportervanguard Assigned Tosbrun  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.9 
Target VersionFixed in Version 
Summary0001942: several broken metapackages
DescriptionDear maintainers,
I discovered that the metapackages kali-linux-all, kali-linux-forensic and kali-linux-sdr are not usable for building a new kali-live-cd.

The reason are this:
kali-linux-all dependes kali-linux-forensic (not installable, missing depending "capstone") and kali-linux-sdr (not installalable, missing depending "hackrf")

It would be nioce, if you could have a look into your repository.
Steps To ReproduceCheck dependencies in aptitude. Or try to build using live-build and add package "kali-linux-all".

Activities

vanguard

2014-12-03 17:15

reporter   ~0002850

I was too fast and forgot this one:

Thank you very much for your help!

Best regards

Hans

sbrun

2014-12-04 08:45

manager   ~0002851

replace depends capstone with python-capstone
package hackrf has been fixed yesterday

vanguard

2014-12-04 11:38

reporter   ~0002852

Sorry to disturb you again. I checked today again and the problem is still not fixed.
As of aptitude says, Kali-linux-forensic still depends capstone (which is not existent), not python-capstone as wished. Could you please recheck the repository?

The other dependency problem with kali-linux-sdr I also mentioned is now working correctly.

Thank you for your efforts.

Best

Hans

rhertzog

2014-12-04 12:18

administrator   ~0002853

Please be a little bit patient, this is fixed with kali-linux-forensic 1.55.23. Please wait until it reaches your mirror. Thank you.

vanguard

2014-12-05 14:36

reporter   ~0002858

Hello Raphael,

I am very sorry, that I have to repoen this bug again. There is still a dependenncy problem. Please look at metapackage kali-linux-sdr.
This is the dependency chain:

kali-linux-all -> kali-linux-sdr -> libgnuradio-osmosdr -> libhackrf (non-existent)

As the missing lib, this cannot be installed.

Sorry, I saw this today.

The repo I am using is directly from kali, as I am using the build straight from github.

Thank you again for your help.

Have a nice weekend!

Hans

rhertzog

2014-12-05 15:00

administrator   ~0002859

Hello vanguard,

no need to be sorry since you are right. The fixed version of libgnuradio-osmosdr is 0.1.0-1kali4+b1 and it was only available in kali-proposed-updates. We forgot to push it to kali... this has now been done.

The next mirror update will bring you the fixed package.

Thanks for the report and sorry for the mess!

For the record, I did test installing kali-linux-sdr in my kali chroot but since I have "kali-proposed-updates" enabled, the installation was working fine...

Issue History

Date Modified Username Field Change
2014-12-03 17:13 vanguard New Issue
2014-12-03 17:15 vanguard Note Added: 0002850
2014-12-03 17:35 rhertzog Assigned To => sbrun
2014-12-03 17:35 rhertzog Status new => assigned
2014-12-04 08:45 sbrun Note Added: 0002851
2014-12-04 08:45 sbrun Status assigned => resolved
2014-12-04 08:45 sbrun Resolution open => fixed
2014-12-04 11:38 vanguard Note Added: 0002852
2014-12-04 11:38 vanguard Status resolved => feedback
2014-12-04 11:38 vanguard Resolution fixed => reopened
2014-12-04 12:18 rhertzog Note Added: 0002853
2014-12-04 12:18 rhertzog Status feedback => resolved
2014-12-04 12:18 rhertzog Resolution reopened => fixed
2014-12-05 14:36 vanguard Note Added: 0002858
2014-12-05 14:36 vanguard Status resolved => feedback
2014-12-05 14:36 vanguard Resolution fixed => reopened
2014-12-05 15:00 rhertzog Note Added: 0002859
2014-12-05 15:00 rhertzog Status feedback => resolved
2014-12-05 15:00 rhertzog Resolution reopened => fixed