View Issue Details

IDProjectCategoryView StatusLast Update
0001996Kali Linux[All Projects] Kali Package Bugpublic2015-01-02 17:01
Reporterjandrusk Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.9 
Target VersionFixed in Version 
Summary0001996: Running apt-get upgrade & apt-get dist-upgrade errors out on package python-configargparse
DescriptionRunning apt-get upgrade & apt-get dist-upgrade errors out on package python-configargparse
Steps To Reproducesudo apt-get upgrade && sudo apt-get dist-upgrade
Additional InformationAfter this operation, 0 B of additional disk space will be used.
Setting up python-configargparse (0.9.3-0kali1) ...
SyntaxError: ('invalid syntax', ('/usr/lib/python2.6/dist-packages/configargparse.py', 16, 65, 'ACTION_TYPES_THAT_DONT_NEED_A_VALUE = {argparse._StoreTrueAction,\n'))

dpkg: error processing python-configargparse (--configure):
 subprocess installed post-installation script returned error exit status 101
dpkg: dependency problems prevent configuration of mitmproxy:
 mitmproxy depends on python-configargparse (>= 0.9.3); however:
  Package python-configargparse is not configured yet.

dpkg: error processing mitmproxy (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-configargparse
 mitmproxy
E: Sub-process /usr/bin/dpkg returned an error code (1)

Activities

kalibgtr34

2015-01-01 15:13

reporter   ~0002925

Same problem with me

Pokeswap

2015-01-01 16:26

reporter   ~0002926

It appears that the latest version in the Kali repos has a syntax error in the code with ACTION_TYPES_THAT_DONT_NEED_A_VALUE. Looking on https://github.com/zorro3/ConfigArgParse/blob/master/configargparse.py , I see
ACTION_TYPES_THAT_DONT_NEED_A_VALUE = {argparse._StoreTrueAction,
    argparse._StoreFalseAction, argparse._CountAction,
    argparse._StoreConstAction, argparse._AppendConstAction}
, but the line is not the same

rhertzog

2015-01-01 19:20

administrator   ~0002927

This has been fixed with python-configargparse 0.9.3-0kali2 that I just uploaded and that will appear on mirrors in the next few hours.

The problem only happens if you have python 2.6 installed. It's due to the fact that the module only supports Python 2.7 and newer.

Issue History

Date Modified Username Field Change
2014-12-31 19:51 jandrusk New Issue
2015-01-01 15:13 kalibgtr34 Note Added: 0002925
2015-01-01 16:26 Pokeswap Note Added: 0002926
2015-01-01 19:20 rhertzog Note Added: 0002927
2015-01-01 19:20 rhertzog Status new => resolved
2015-01-01 19:20 rhertzog Resolution open => fixed
2015-01-01 19:20 rhertzog Assigned To => rhertzog