View Issue Details

IDProjectCategoryView StatusLast Update
0003054Kali Linux[All Projects] Kali Package Bugpublic2016-02-23 16:40
ReporterMqFuhA9Cze Assigned Torhertzog  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version 
Summary0003054: King Phisher Client missing Requirement
DescriptionThe King Phisher package is missing the python-gi-cairo dependency. This results in a crash when the "View Campaign" tab is loaded.

The following is the stack trace from the error.

Error Type: exceptions.TypeError
Error Details: TypeError("Couldn't find foreign struct converter for 'cairo.Context'",)
Error UID: 56435b34-1fe9-46e1-988e-3b135aaec401
RPC Error: N/A (Not a remote RPC error)
King Phisher Version: 1.1.0
Platform Version: Linux: Kali kali-rolling kali-rolling
Python Version: 2.7.11
Gtk Version: 3.18.7
Timezone: America/New_York

Thread Information:
=> MainThread (alive=True daemon=False)

Stack Trace:
Traceback (most recent call last):
File "/usr/share/king-phisher/king_phisher/client/windows/main.py", line 255, in signal_notebook_switch_page
notebook.emit('switch-page', notebook.get_nth_page(index), index)
TypeError: Couldn't find foreign struct converter for 'cairo.Context'
Steps To ReproduceFirst the py2-ipaddress and pytz packages need to be reinstalled so the client can authenticate and log into the server. There is a seperate bug report open for that issue (0003041). Once those packages are fixed users just need to log into the server and then select the "View Campaign" ta from the client.

Activities

rhertzog

2016-02-23 16:40

administrator   ~0004755

This has been fixed in king-phisher 1.1.0+git20160222-0kali2 now in kali-rolling.

Issue History

Date Modified Username Field Change
2016-02-09 21:58 MqFuhA9Cze New Issue
2016-02-23 16:40 rhertzog Note Added: 0004755
2016-02-23 16:40 rhertzog Status new => resolved
2016-02-23 16:40 rhertzog Resolution open => fixed
2016-02-23 16:40 rhertzog Assigned To => rhertzog