View Issue Details

IDProjectCategoryView StatusLast Update
0003098Kali Linux[All Projects] Kali Package Bugpublic2016-03-13 19:53
Reportercaspa Assigned Torhertzog  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2016.2 
Summary0003098: Upgrade to 2016.2 (Kali-linux-4.4.0 amd64 image) causes boot failure. Grub screen stuck on "Loading to RAM disk".
DescriptionI have a clean install of Kali Rolling 2016.1 with a 4.3.0 amd64 image (obtained directly from Kali.org and not modified in any way) on a dedicated SSD of a brand-new Acer machine. It worked fine for a couple of weeks until I ran *apt-get update* and *dist-upgrade* yesterday, which added a 4.4.0 image to Kali.

Now Grub bootloader has two entries of each kernel in advanced menu options, but it defaults to the new 4.4.0 image, which does not boot at all. It immediately gets stuck on "Loading to RAM Disk", at which point the machine heats up and the fans work double-time.

So now only a cold-boot, and manual selection of the original 4.3 image in Grub makes it boot into Kali.
Steps To Reproduce1) Install a Kali Rolling 4.3.0 amd64 image onto a dedicated hard driUpgrade to 2016.2 (Kali-linux-4.4.0 amd64 image) causes boot failure. Grub screen stuck on "Loading to RAM disk".ve using an official ISO from kali.org.
2) run 'apt-get update' and 'apt-get dist-upgrade'.
3) reboot
4) And watch Grub freeze while it tries to load the new 4.4 kernel.
Additional InformationAlternatively, cold boot to get back into Grub, and select Advanced Options to see both 4.3 and 4.4 images.
Now, select 4.3.0 image to boot into it manually.
Once in Kali X session, look in the /boot directory to view both kernels.

The only temporary hack, short of the (ill-advised) purging of the new kernel & apt-pinning it to prevent new upgrades, is to set the original 4.3 image via grub-set-default, and to change the GRUB_SAVEDEFAULT value to "true" in /etc/default/grub.

Activities

rhertzog

2016-02-26 10:39

administrator   ~0004764

What version of initramfs-tools do you have?

Have you tried regenerating your initrd with "update-initramfs -u -k all"?

It seems weird that it fails this early in the process. Linux 4.4 might have regression but Linux 4.4 has not even been loaded yet according to your description.

Can you edit the 4.4 boot entry (with "e") and drop the "quiet" parameter before booting to see if you actually see other kernel messages?

deltaf

2016-02-26 18:07

reporter   ~0004770

I've had the same problem.

initramfs-tools is already the newest version (0.123)

I've tried with "update-initramfs -u -k all" but nothing.

I've tried to drop "quiet" parameter but the boot go in loop always.

caspa

2016-02-26 22:44

reporter   ~0004773

@rhertzog - My initramfs-tools is version 0.123

update-initramfs does not have any impact.

As far as 4.4 image not loading, you are correct. It does not even get to load, because Grub freezes while loading to RAM.

I changed the quiet boot parameter to panic=5, but it doesn't seem to make any difference.

rhertzog

2016-02-29 10:12

administrator   ~0004791

Do you use UEFI boot?

You are probably affected by https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815125

Does booting with "efi=old_map" work?

Quist1967

2016-03-01 10:20

reporter   ~0004795

@rhertzog

I can confirm this bug too. Tested out your boot parameters, but it doesn't work for me. I am in UEFI mode.
The only currently workaround so far is to boot with 4.3 kernel like caspa said.

caspa

2016-03-07 19:23

reporter   ~0004824

@rhertzog Sorry for the delay in responding.
I only have a few days of lab access left for my PWK course, and I've downgraded (apt-pinned the 4.4 image) for now, so I can focus on the studies.

Should be able to test out the extra boot parameters referenced in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815125
in a week or so.

I am also using non-secure UEFI boot, as legacy mode does not play well with Kali Rolling.

Slyticoon

2016-03-09 19:01

reporter   ~0004833

I am having the same issue after updating from 4.0.0.

rhertzog

2016-03-11 15:37

administrator   ~0004842

We have uploaded linux_4.4.4-2kali2 to kali-dev. Can you try this version and let us know if it fixes the boot issue you have?

DreamWalker

2016-03-13 13:55

reporter   ~0004844

@rhertzog
I had this problem too, updated today to 4.4.4-2kali2 (2016-03-11) and the problem was solved.
Thank you.

caspa

2016-03-13 18:36

reporter   ~0004845

@rhertzog are the following still the correct repos to add to sources:

deb http://http.kali.org/kali kali-dev main contrib non-free
deb http://http.kali.org/kali kali-dev main/debian-installer
deb-src http://http.kali.org/kali kali-dev main contrib non-free

caspa

2016-03-13 19:02

reporter   ~0004846

@rhertzog,

I installed the 4.4.4-2kali2 headers & image, and it looks like it's patched correctly. The boot issue is gone.

You can mark it solved. ;)

Thank you for your help.

rhertzog

2016-03-13 19:53

administrator   ~0004847

Great, closing it.

The correct repository is kali-rolling, you can add kali-dev temporarily for a one-off test but you should not keep it longer than that.

deb http://http.kali.org/kali kali-rolling main contrib non-free

Issue History

Date Modified Username Field Change
2016-02-26 06:39 caspa New Issue
2016-02-26 10:30 rhertzog Assigned To => rhertzog
2016-02-26 10:30 rhertzog Status new => assigned
2016-02-26 10:39 rhertzog Note Added: 0004764
2016-02-26 11:06 rhertzog Status assigned => feedback
2016-02-26 18:07 deltaf Note Added: 0004770
2016-02-26 22:44 caspa Note Added: 0004773
2016-02-26 22:44 caspa Status feedback => assigned
2016-02-29 10:12 rhertzog Note Added: 0004791
2016-03-01 10:20 Quist1967 Note Added: 0004795
2016-03-07 19:23 caspa Note Added: 0004824
2016-03-09 19:01 Slyticoon Note Added: 0004833
2016-03-11 15:37 rhertzog Note Added: 0004842
2016-03-11 15:37 rhertzog Status assigned => feedback
2016-03-13 13:55 DreamWalker Note Added: 0004844
2016-03-13 18:36 caspa Note Added: 0004845
2016-03-13 18:36 caspa Status feedback => assigned
2016-03-13 19:02 caspa Note Added: 0004846
2016-03-13 19:53 rhertzog Note Added: 0004847
2016-03-13 19:53 rhertzog Status assigned => resolved
2016-03-13 19:53 rhertzog Fixed in Version => 2016.2
2016-03-13 19:53 rhertzog Resolution open => fixed
2016-03-17 06:24 newhack Issue cloned: 0003153
2016-03-17 06:25 newhack Issue cloned: 0003157
2016-03-17 06:26 newhack Issue cloned: 0003162