View Issue Details

IDProjectCategoryView StatusLast Update
0003275Kali Linux[All Projects] Kali Package Improvementpublic2016-05-16 23:38
Reportersteev Assigned Tosbrun  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2016.2 
Summary0003275: hackrf udev rule not installed correctly
DescriptionI'm not sure where the bug is exactly (I believe it's upstream) but the hackrf package has the following in its sources:

libhackrf0.udev:host/libhackrf/53-hackrf.rules

What *actually* seems to be installed is a file called

60-libhackrf0.rules

and the contents are:
steev@eren:~/sandbox/hackrf/hackrf-2015.07.2/debian $ cat ~/60-libhackrf0.rules
host/libhackrf/53-hackrf.rules

This is obviously an invalid udev rule;

The actual contents should be:
ATTR{idVendor}=="1d50", ATTR{idProduct}=="604b", SYMLINK+="hackrf-jawbreaker-%k", MODE="660", GROUP="plugdev"
ATTR{idVendor}=="1d50", ATTR{idProduct}=="6089", SYMLINK+="hackrf-one-%k", MODE="660", GROUP="plugdev"
ATTR{idVendor}=="1d50", ATTR{idProduct}=="cc15", SYMLINK+="rad1o-%k", MODE="660", GROUP="plugdev"
ATTR{idVendor}=="1fc9", ATTR{idProduct}=="000c", SYMLINK+="nxp-dfu-%k", MODE="660", GROUP="plugdev"

Additional InformationI'm setting this to major because a) i don't believe hackrf works properly without the rules in place, and b) looking in the journal, it says the rules file is invalid (and I'm not sure if it continues processing other rules and ignores the invalid one, or just exits then.

I came across this when tracking down why my wlan interfaces are still getting the systemd predictable names even with net.ifnames=0 set on the cmdline.

Activities

sbrun

2016-05-09 10:03

manager   ~0005206

Thanks for the report.
The problem is in the debian package. I opened a bug report:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=823810

steev

2016-05-16 23:38

developer   ~0005251

2015.07.2-10 contains the fix

Issue History

Date Modified Username Field Change
2016-05-04 18:25 steev New Issue
2016-05-04 19:14 rhertzog Assigned To => sbrun
2016-05-04 19:14 rhertzog Status new => assigned
2016-05-09 10:03 sbrun Note Added: 0005206
2016-05-16 23:38 steev Note Added: 0005251
2016-05-16 23:38 steev Status assigned => resolved
2016-05-16 23:38 steev Fixed in Version => 2016.2
2016-05-16 23:38 steev Resolution open => fixed