View Issue Details

IDProjectCategoryView StatusLast Update
0003496Kali Linux[All Projects] Tool Upgradepublic2016-09-01 13:07
Reporterccmcdee Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2016.2 
Summary0003496: Update the git package to 1:2.9.3-1
DescriptionIt seems that kali repos have an older version of git than the one currently in the (testing branch) Debian repos:


root@offsec:~/Desktop/metasploit-framework# apt policy git
git:
  Installed: 1:2.8.1-1
  Candidate: 1:2.8.1-1
  Version table:
 *** 1:2.8.1-1 500
        500 http://http.kali.org/kali kali-rolling/main amd64 Packages
        100 /var/lib/dpkg/status


root@offsec:~# git --version
git version 2.8.1

================================================================
Package git

    stretch (testing) (vcs): fast, scalable, distributed revision control system
    1:2.9.3-1: amd64 arm64 armel armhf i386 mips mips64el mipsel powerpc ppc64el s390x


Could this be updated please!

===========================================
Running the current version produces this output:
root@offsec:~# git status
fatal: bad object HEAD
fatal: 'git status --porcelain' failed in submodule Templates/Git/git
root@offsec:~#

It is unknown if this is reflected do to version or something else.

Activities

ccmcdee

2016-08-24 18:53

reporter   ~0005670

So, removing the git downloaded and compiled from git.com seems to have solved the bad object HEAD issue.

sbrun

2016-09-01 13:07

manager   ~0005726

we have now same version in debian testing and in kali-rolling: version 1:2.9.3-1

Issue History

Date Modified Username Field Change
2016-08-24 15:12 ccmcdee New Issue
2016-08-24 18:53 ccmcdee Note Added: 0005670
2016-09-01 13:07 sbrun Note Added: 0005726
2016-09-01 13:07 sbrun Status new => resolved
2016-09-01 13:07 sbrun Resolution open => fixed
2016-09-01 13:07 sbrun Fixed in Version => 2016.2