2017-03-24 00:11 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003845Kali Linux[All Projects] Kali Package Bugpublic2017-02-13 20:30
ReporterMister_X 
Assigned Torhertzog 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version2016.2 
Target VersionFixed in Version2017.1 
Summary0003845: gqrx package outdated and doesn't work - package removal
Descriptiongqrx package (v2.3) from Kali doesn't work anymore. It doesn't start a GUI and fails to do any action offered due to failure (such as reset configuration). Even further tries to start it fail.

gqrx-sdr package (maintained by debian) works fine with HackRF and RTL-SDR and is up to date (v2.6).

gqrx package should be removed (it also conflicts when trying to install gqrx-sdr afterward; purging it then installing gqrx-sdr fixes installation).
Attached Files

-Relationships
+Relationships

-Notes

~0006301

rhertzog (administrator)

Thank you for the notice. I updated the meta-package kali-linux-sdr 2017.1.2 to pull gqrx-sdr, I modified that gqrx-sdr package to conflict with gqrx and I provided a transitional gqrx package pulling in gqrx-sdr.

I asked Debian to add the required conflicts/replaces headers in http://bugs.debian.org/854056

Hopefully that should handle the transition nicely.
+Notes

-Issue History
Date Modified Username Field Change
2017-01-24 20:34 Mister_X New Issue
2017-01-25 08:24 rhertzog Assigned To => rhertzog
2017-01-25 08:24 rhertzog Status new => assigned
2017-02-03 13:58 rhertzog Status assigned => resolved
2017-02-03 13:58 rhertzog Resolution open => fixed
2017-02-03 13:58 rhertzog Fixed in Version => 2017.1
2017-02-03 13:58 rhertzog Note Added: 0006301
+Issue History