View Issue Details

IDProjectCategoryView StatusLast Update
0004006Kali Linux[All Projects] Kali Package Bugpublic2017-05-11 12:32
Reporteryennefer1173 Assigned Tosbrun  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.2 
Target VersionFixed in Version 
Summary0004006: Armitage gives error on launch.
DescriptionWhen I start armitage from the icon, it does not start at all(even does not show errors). When started from console it outputs the following error: The Parallel GC can not be combined with -XX:ParallelGCThreads=0 . So I fixed it by removing -XX:+AggressiveHeap from /usr/share/armitage/armitage . This seems to be an issue after the recent openjdk update.
Steps To ReproduceStart armitage.
Additional InformationThis is on fully updated kali 2017.1 . It is a common issue on nethunter as well, but the workaround I specified is implemented in it. I reported this issue for nethunter(and arm devices) some time ago: https://bugs.kali.org/view.php?id=3641 . It was not relevant for x86 or x64 devices though.

Activities

LeeRock

2017-05-10 02:54

reporter   ~0006652

Work around:

cd /usr/share/armitage/
java -jar armitage.jar

sbrun

2017-05-11 12:32

manager   ~0006659

fixed in new version 20150812-1kali2

Issue History

Date Modified Username Field Change
2017-05-09 21:11 yennefer1173 New Issue
2017-05-10 02:54 LeeRock Note Added: 0006652
2017-05-10 08:02 rhertzog Assigned To => sbrun
2017-05-10 08:02 rhertzog Status new => assigned
2017-05-11 12:32 sbrun Status assigned => resolved
2017-05-11 12:32 sbrun Resolution open => fixed
2017-05-11 12:32 sbrun Note Added: 0006659