2018-07-23 01:56 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004132Kali Linux[All Projects] General Bugpublic2018-02-21 09:41
Assigned To 
Product Version2017.1 
Target VersionFixed in Version 
Summary0004132: CPU Soft lockup (Skylake 6700HQ) due to nouveau - Doesn't finish booting
DescriptionKali weekly image http://cdimage.kali.org/kali-weekly/kali-linux-2017-W16-amd64.iso doesn't really finish booting, I get CPU soft lock up which lead to kernel oops and that makes the machine unuseable (X doesn't even start, all I get is the console).

Based on the screenshots attached, they seem to be in nouveau. And those oops/issues keep coming on the screen until I force turn off.
Additional InformationInstalling 2016.2 works but last time I did, then updated it (which included the kernel), it failed to boot due to nouveau blocking at boot time.

It's an Dell laptop with dual GPU: Intel + Nvidia 960M.
CPU is i7 6700HQ.

Here is the exact laptop model: Dell Inspiron i7559-5012GRY
Attached Files

child of 0003962closed CPU Soft lockup (Skylake 6700HQ) due to nouveau - Doesn't finish booting 



Sairentoyukihyou (reporter)

Can confirm, I've got exactly the same problem.
Kali worked on 2016.2 (with screen flickering) but on 2017.1 it displays the errors shown in OP's image.

Laptop System: Aspire E5-771G
CPU: Intel i5 4210U
Dual GPU: IntelĀ® HD Graphics 4400 & Nvidia Geforce 840M


broomdodger (reporter)

when at the grub startup
have you tried e (for edit)
then in the linux section
insert nomodeset before the word ro
then ctrl-x or F10 to boot


bigfoot18 (reporter)

Can also confirm this bug on Kali 2017.1

Laptop: Dell Inspiron 15 7559
CPU: Intel I7 6700HQ Skylake
Dual GPU: Intel HD Graphics 530 + Nvidia Geforce 960M

Only get this error when trying to load USB Persistence. Does not happen when I load Kali Live Image.


Mister_X (reporter)

bigfoot18, it only happens on recent kernels. If I installed 2016.1 and did not update it, it would not trigger. However, if I updated, I would get a more recent kernel (which 2017.1 has) that triggers.


bigfoot18 (reporter)

Mister_X, I hope this gets resolved soon. I tried using other versions of Kali such as the 32bit version. Nothing changed, still get the same error when trying to boot into persistence. Live still works fine though.


Jarlnonnekens112 (reporter)

Having the same issue with my nvidia laptop. When i use nomodeset it boots up. But then it uses my integrated cpu graphics but i want to use my 960m. Ive tried to install nvidia driver on the way kali tolt me on there site and it wont work ive also tried to disable nouveau with the nvidia driver installed and it isnt booting. Ive been bussy with the issue for 3 days ive gave it up and have tried evry thing i thing im gonna wait til they fixed it.


Jarlnonnekens112 (reporter)

Msi laptop *


g0tmi1k (administrator)

Due to the age of the OS (Kali Moto [v1], Kali Safi [v2], Kali Rolling 2016.x/2017.1), these legacy versions are no longer supported.
We will be closing this ticket due to inactivity.

Please could you see if you are able to replicate this issue with the latest version of Kali Linux - https://www.kali.org/downloads/)?

If you are still facing the same problem, feel free to re-open the ticket. If you choose to do this, could you provide more information to the issue you are facing,and also give information about your setup?
For more information, please read: https://kali.training/topic/filing-a-good-bug-report/

-Issue History
Date Modified Username Field Change
2017-08-05 01:50 bigfoot18 New Issue
2017-08-05 01:50 bigfoot18 Issue generated from: 0003962
2017-08-05 01:50 bigfoot18 Relationship added child of 0003962
2017-08-05 01:50 bigfoot18 Note Added: 0006967
2017-08-05 01:50 bigfoot18 Note Added: 0006968
2017-08-05 01:50 bigfoot18 Note Added: 0006969
2017-08-05 01:50 bigfoot18 Note Added: 0006970
2017-08-05 01:50 bigfoot18 Note Added: 0006971
2017-08-18 08:59 Jarlnonnekens112 Note Added: 0007006
2017-08-18 08:59 Jarlnonnekens112 Note Added: 0007007
2018-02-21 09:41 g0tmi1k Note Added: 0008736
2018-02-21 09:41 g0tmi1k Status new => closed
+Issue History