2018-10-15 08:27 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004909Kali Linux[All Projects] Kali Package Bugpublic2018-09-06 08:09
Reportersrccsebt 
Assigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version2018.2 
Target VersionFixed in Version2018.4 
Summary0004909: Mono package has a bug
DescriptionIt looks like the Mono package included in Kali's repos has a bug. I believe it is related to this github issue - https://github.com/mono/mono/issues/6752. The mono package in Kali is throwing the exact same error (the magic number error).

I can recreate this when installing Veil, and generating a csharp payload which crashes mono. This issue did not exist in prior versions and the c# code in Veil hasn't changed.
Attached Files

-Relationships
+Relationships

-Notes

~0009459

elwood (administrator)

We are looking into this. Thanks for the submission.

~0009460

rhertzog (administrator)

This has been fixed in Debian unstable already:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=899222

Unfortunately the package did not migrate into testing. I'll cherry pick the fixed version of mono (4.6.2.7+dfsg-2) into kali-rolling.

~0009589

sbrun (manager)

fixed version 4.6.2.7+dfsg-2 is in kali-rolling
+Notes

-Issue History
Date Modified Username Field Change
2018-08-18 13:15 srccsebt New Issue
2018-08-18 13:15 srccsebt Issue generated from: 0004906
2018-09-06 08:09 sbrun Status acknowledged => resolved
2018-09-06 08:09 sbrun Resolution open => fixed
2018-09-06 08:09 sbrun Fixed in Version => 2018.4
2018-09-06 08:09 sbrun Note Added: 0009589
+Issue History