View Issue Details

IDProjectCategoryView StatusLast Update
0004978Kali Linux[All Projects] General Bugpublic2019-03-29 16:06
ReporterrhertzogAssigned Torhertzog 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.3 
Target VersionFixed in Version2019.2 
Summary0004978: Get rid of pyside and shiboken (deprecated by pyside2)
Descriptionpyside (version 1) and shiboken have been dropped from Debian Testing a while ago as it's deprecated, applications should switch to pyside2 (or something else). We have kept it around in Kali for a while but now is time to get applications updated or removed.

The following applications do depend on pyside 1.x currently:
- iphone-backup-analyzer
- rfcat
- sparta (for python-pyside.qtwebkit which is not available in pyside2!)
- ubertooth (in recommends)

We should open upstream tickets asking them their plan to switch to pyside2 or something else.
Additional InformationCurrent status: bugs filed for all packages
[X] iphone-backup-analyzer: https://github.com/PicciMario/iPhone-Backup-Analyzer-2/issues/16 -> dropped from kali-rolling
[X] rfcat: https://github.com/atlas0fd00m/rfcat/issues/26
[X] sparta: https://github.com/SECFORCE/sparta/issues/94
[X] ubertooth: https://bugs.debian.org/919388

Activities

rhertzog

2019-01-15 11:10

administrator   ~0010212

So I'm looking into iphone-backup-analyzer. Our package is a python application which used to be hosted on http://ipbackupanalyzer.com/ That domain doesn't contain anything. But I found the code on GitHub (in the account of the upstream author): https://github.com/PicciMario/iPhone-Backup-Analyzer-2

The application hasn't seen any update since 2014, I believe it's highly unlikely that it will be ever updated to work with pyside2. The package is apparently not referenced in the PWK course but it's part of kali-linux-forensic. @dookie can we get rid of that package in Kali ?

Note that our tools.kali.org page (https://tools.kali.org/forensics/iphone-backup-analyzer) links to a wrong page though, it links to https://sourceforge.net/p/iphoneanalyzer/ which is a separate java application.

I still filed https://github.com/PicciMario/iPhone-Backup-Analyzer-2/issues/16 to inform upstream.

rhertzog

2019-01-15 11:42

administrator   ~0010213

I filed the issue for rfcat: https://github.com/atlas0fd00m/rfcat/issues/26
In the worst case, we should be able to do the port to Pyside2 ourselves by copying what was done in ubertooth: https://github.com/greatscottgadgets/ubertooth/commit/7985d95f67819e4e9eb0db0f71eb17a564363faa

rhertzog

2019-01-15 13:21

administrator   ~0010214

I filed the issue for sparta: https://github.com/SECFORCE/sparta/issues/94

There's hasn't been much upstream activity lately, it's not clear if the issue will be fixed in a timely manner. @dookie, would it be problematic to drop sparta from Kali? It's not referenced in the PWK course but it's part of the kali-linux-full meta-package.

rhertzog

2019-01-15 13:26

administrator   ~0010215

For ubertooth, the software has already been updated to use PySide2 but the Debian package still has dependencies on the old package. I filed a Debian bug asking the maintainer to update the dependencies: https://bugs.debian.org/919388

dookie

2019-01-15 14:36

administrator   ~0010217

@rhertzog I don't see any issue with removing iphone-backup-analyzer

rhertzog

2019-01-31 16:05

administrator   ~0010246

Last edited: 2019-01-31 16:07

View 2 revisions

I just uploaded a new rfcat relying on pyside2 (version 170508-0kali3).

rhertzog

2019-01-31 16:07

administrator   ~0010247

Last edited: 2019-01-31 16:07

View 2 revisions

ubertooth has been fixed on the Debian side as well (version 2018.12.R1-2).

rhertzog

2019-02-08 10:06

administrator   ~0010270

I uploaded kali-meta 2019.2.0 which drops iphone-backup-analyzer from the metapackage and I removed the package from kali-dev.

For sparta, I tried to ping the upstream developers through twitter since I haven't gotten an answer: https://twitter.com/raphaelhertzog/status/1093812023815819266

st3r30byt3

2019-02-09 14:59

reporter   ~0010275

Hi. Thanks for the ping on twitter. We pushed a fix for sparta today. Should be fine now on v1.0.4.

sbrun

2019-02-11 14:21

manager   ~0010283

sparta updated to version 1.0.4-0kali1

rhertzog

2019-02-11 14:56

administrator   ~0010284

@st3r30byt3 Thanks! Note however that you are still based on Qt4... you need to switch to Qt5 to be safe. See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=875109 about the future removal of python-qt4 from Debian.

Issue History

Date Modified Username Field Change
2018-09-11 14:27 rhertzog New Issue
2018-09-11 14:27 rhertzog Assigned To => rhertzog
2018-09-11 14:27 rhertzog Status new => assigned
2018-09-18 13:08 rhertzog Summary Get rid of pyside (deprecated by pyside2) => Get rid of pyside and shiboken (deprecated by pyside2)
2018-09-18 13:08 rhertzog Description Updated View Revisions
2019-01-15 11:10 rhertzog Note Added: 0010212
2019-01-15 11:42 rhertzog Note Added: 0010213
2019-01-15 13:21 rhertzog Note Added: 0010214
2019-01-15 13:24 rhertzog Additional Information Updated View Revisions
2019-01-15 13:26 rhertzog Note Added: 0010215
2019-01-15 14:36 dookie Note Added: 0010217
2019-01-31 16:05 rhertzog Additional Information Updated View Revisions
2019-01-31 16:05 rhertzog Note Added: 0010246
2019-01-31 16:07 rhertzog Additional Information Updated View Revisions
2019-01-31 16:07 rhertzog Note Added: 0010247
2019-01-31 16:07 rhertzog Note Edited: 0010246 View Revisions
2019-01-31 16:07 rhertzog Note Edited: 0010247 View Revisions
2019-02-08 10:04 rhertzog Additional Information Updated View Revisions
2019-02-08 10:06 rhertzog Note Added: 0010270
2019-02-09 14:59 st3r30byt3 Note Added: 0010275
2019-02-11 14:21 sbrun Additional Information Updated View Revisions
2019-02-11 14:21 sbrun Note Added: 0010283
2019-02-11 14:56 rhertzog Note Added: 0010284
2019-03-29 16:06 rhertzog Status assigned => resolved
2019-03-29 16:06 rhertzog Resolution open => fixed
2019-03-29 16:06 rhertzog Fixed in Version => 2019.2