View Issue Details

IDProjectCategoryView StatusLast Update
0005053Kali Linux[All Projects] General Bugpublic2018-10-26 17:16
Reportertor Assigned Toelwood  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.3 
Target VersionFixed in Version 
Summary0005053: Tor exit nodes blacklisted on package mirror
DescriptionMachines connected through Tor cannot update packages.

...
557 upgraded, 24 newly installed, 0 to remove and 4 not upgraded.
Need to get 968 MB of archives.
After this operation, 340 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Err:1 http://kali.download/kali kali-rolling/main amd64 dpkg amd64 1.19.2kali1
  403 Forbidden [IP: 104.18.243.114 80]
Err:2 http://kali.download/kali kali-rolling/main amd64 gzip amd64 1.9-2.1
  403 Forbidden [IP: 104.18.243.114 80]
Err:3 http://kali.download/kali kali-rolling/main amd64 ncurses-bin amd64 6.1+20181013-1
  403 Forbidden [IP: 104.18.243.114 80]
Err:4 http://kali.download/kali kali-rolling/main amd64 libgdbm6 amd64 1.18-2
  403 Forbidden [IP: 104.18.243.114 80]
Err:5 http://kali.download/kali kali-rolling/main amd64 libgdbm-compat4 amd64 1.18-2
  403 Forbidden [IP: 104.18.243.114 80]
Err:6 http://kali.download/kali kali-rolling/main amd64 perl-base amd64 5.26.2-7+b1
  403 Forbidden [IP: 104.18.243.114 80]
...

The kali.download mirror blocks most Tor exit nodes. I've had to test more than 10 exit nodes before finding one which was not blacklisted.

Thanks in advance for your help,

A Tor user

Activities

elwood

2018-10-26 15:40

administrator   ~0009838

Thanks for calling this out. I think it should be corrected now. Please let me know if you still encounter the issue.

Thanks!

tor

2018-10-26 16:42

reporter   ~0009839

I've tried installing a few packages and everything worked fine. Hard to say if I was lucky in my exit node choice or if the problem is fixed from this single test. But if you changed the cloudflare settings for kali.download then I guess the problem is truly fixed and this issue can be closed.

Thanks a lot for your quick and efficient help!

elwood

2018-10-26 17:16

administrator   ~0009840

Thanks for the report! If you notice this happening again in the future just let us know.

Issue History

Date Modified Username Field Change
2018-10-26 15:13 tor New Issue
2018-10-26 15:40 elwood Assigned To => elwood
2018-10-26 15:40 elwood Status new => assigned
2018-10-26 15:40 elwood Note Added: 0009838
2018-10-26 16:42 tor Note Added: 0009839
2018-10-26 17:16 elwood Status assigned => resolved
2018-10-26 17:16 elwood Resolution open => fixed
2018-10-26 17:16 elwood Note Added: 0009840