View Issue Details

IDProjectCategoryView StatusLast Update
0005122Kali Linux[All Projects] Kali Package Bugpublic2019-01-25 14:01
ReporterMister_XAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005122: jsql fails start due to exceptions
DescriptionRunning it without any parameters returns:

Error occurred during initialization of boot layer
java.lang.module.FindException: Module java.xml.bind not found

When editing /usr/bin/jsql and removing --add-modules parameter, it still fails to run:

ERROR root:35 - Unhandled Exception on main
java.lang.NoClassDefFoundError: javax/xml/bind/JAXBException
    at com.jsql.model.injection.vendor.Vendor.<clinit>(Vendor.java:11)
    at com.jsql.model.InjectionModel.<init>(InjectionModel.java:121)
    at com.jsql.MainApplication.main(MainApplication.java:58)
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.JAXBException
    at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
    at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
    ... 3 more

Exception: java.lang.NullPointerException thrown from the UncaughtExceptionHandler in thread "main"

It looks like there is a recent commit to fix the issue (untested) but they haven't made a release yet: https://github.com/ron190/jsql-injection/commit/a2f749774aa985ed55129753650ad63f6318bc06

Activities

sbrun

2019-01-25 14:01

manager   ~0010235

fixed in version 0.81-0kali2

Issue History

Date Modified Username Field Change
2018-11-26 23:41 Mister_X New Issue
2019-01-25 14:01 sbrun Assigned To => sbrun
2019-01-25 14:01 sbrun Status new => resolved
2019-01-25 14:01 sbrun Resolution open => fixed
2019-01-25 14:01 sbrun Note Added: 0010235