View Issue Details

IDProjectCategoryView StatusLast Update
0005200Kali Linux[All Projects] Kali Package Bugpublic2019-01-10 14:42
ReporterskacpAssigned Tosbrun 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0005200: king-phisher site cloner not working
Descriptionin refrence to bug 0005198

commenting out import mdx_partial_gfm as mentioned in https://bugs.kali.org/view.php?id=5198#c10175
leads to a new problem - the site cloner doesn't work anymore.
which is not suprising if you look at the original trace, as this is the module using mdx_partial_gfm

eventually the initial problem is caused by: https://github.com/securestate/king-phisher/wiki/Web-Cloning#requiring-webkit2gtk

Activities

sbrun

2019-01-10 14:04

manager   ~0010189

I have no problem to use site cloner. Can you give more informations:
- what did you do?
- what did you expect?
- what did you get?
- do you get an error message? (which one)

mdx_partial_gfm is used by default but it's not required if I understand correctly the code.
About webkit: we don't have gir1.2-webkit2-3.0 but gir1.2-webkit2-4.0 in Kali. It should not be a problem.

skacp

2019-01-10 14:33

reporter   ~0010190

hm, maybe a case of 'have you tried turning it off and on again' ....

I can confirm, the site cloner works as expected again. I tried the same homepages as yesterday und the site cloner is fully functioning.
So case can be closed.

sbrun

2019-01-10 14:42

manager   ~0010191

thanks for your feedback

Issue History

Date Modified Username Field Change
2019-01-07 14:54 skacp New Issue
2019-01-10 14:04 sbrun Assigned To => sbrun
2019-01-10 14:04 sbrun Status new => feedback
2019-01-10 14:04 sbrun Note Added: 0010189
2019-01-10 14:33 skacp Note Added: 0010190
2019-01-10 14:33 skacp Status feedback => assigned
2019-01-10 14:42 sbrun Status assigned => resolved
2019-01-10 14:42 sbrun Resolution open => fixed
2019-01-10 14:42 sbrun Note Added: 0010191