View Issue Details

IDProjectCategoryView StatusLast Update
0005219Kali Linux[All Projects] Kali Package Bugpublic2019-03-29 14:52
ReporterboloAssigned Tosbrun 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0005219: JTR doesn't start
Descriptionlsb_release -a
No LSB modules are available.
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: 2019.1
Codename: n/a

after update the JTR package it doesn't work anymore.
Steps To Reproducejohn --test
fopen: $JOHN/john.local.conf: No such file or directory

echo $JOHN
<empty row>

Additional Informationno john.local.conf found on system, also softlink from /etc/john/john.con to /etc/john/john.local.conf and export JOHN=/etc/john don't fix the problem

Activities

sbrun

2019-01-25 08:33

manager   ~0010232

Maybe you chose to keep the old config file /etc/john/john.conf during the upgrade.
The config file /etc/john/john.conf should look like the file /usr/share/john/john.conf

bolo

2019-01-25 09:34

reporter   ~0010233

root@kali:/etc/john# mv john.conf john.conf.bck
root@kali:/etc/john# cp -p /usr/share/john/john.conf .
root@kali:/etc/john# john --test
fopen: $JOHN/john.local.conf: No such file or directory
root@kali:/etc/john#

Also i'm pretty sure apt didn't ask me nothing about john conf file during upgrade
dpkg-reconfigure john doesn't work, there is another method to fix the problem?

bolo

2019-01-25 09:51

reporter   ~0010234

apt-get -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confnew install --reinstall john john-data
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/30,9 MB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 429126 files and directories currently installed.)
Preparing to unpack .../john-data_1.8.0.13-jumbo-1-0kali4_all.deb ...
Unpacking john-data (1.8.0.13-jumbo-1-0kali4) over (1.8.0.13-jumbo-1-0kali4) ...
Preparing to unpack .../john_1.8.0.13-jumbo-1-0kali4_amd64.deb ...
Unpacking john (1.8.0.13-jumbo-1-0kali4) over (1.8.0.13-jumbo-1-0kali4) ...
Processing triggers for man-db (2.8.5-1) ...
Setting up john-data (1.8.0.13-jumbo-1-0kali4) ...
Setting up john (1.8.0.13-jumbo-1-0kali4) ...

Also reinstall packages doesn't fix

rhertzog

2019-03-29 14:02

administrator   ~0010455

Could it be that you using a "john" binary which is not the one provided by Kali? Try "which john" on the command line, if it doesn't return /usr/sbin/john then you are using something else.

Please give us the output of "john -h|head -n 1" also.

In any case, I can't reproduce the issue either.

bolo

2019-03-29 14:27

reporter   ~0010456

The john binary is in /usr/sbin

Here's the output command you asked
# john -h|head -n 1
John the Ripper 1.8.0.13-jumbo-1-bleeding-973a245b96 2018-12-17 20:12:51 +0100 OMP [linux-gnu 64-bit x86_64 AVX AC]

But after my last full-upgrade the problem has gone

bolo

2019-03-29 14:33

reporter   ~0010457

For me the bug report could be closed

Issue History

Date Modified Username Field Change
2019-01-24 13:44 bolo New Issue
2019-01-25 08:33 sbrun Assigned To => sbrun
2019-01-25 08:33 sbrun Status new => feedback
2019-01-25 08:33 sbrun Note Added: 0010232
2019-01-25 09:34 bolo Note Added: 0010233
2019-01-25 09:34 bolo Status feedback => assigned
2019-01-25 09:51 bolo Note Added: 0010234
2019-03-29 14:02 rhertzog Priority high => normal
2019-03-29 14:02 rhertzog Status assigned => feedback
2019-03-29 14:02 rhertzog Note Added: 0010455
2019-03-29 14:27 bolo Note Added: 0010456
2019-03-29 14:27 bolo Status feedback => assigned
2019-03-29 14:33 bolo Note Added: 0010457
2019-03-29 14:52 sbrun Status assigned => closed
2019-03-29 14:52 sbrun Resolution open => no change required