View Issue Details

IDProjectCategoryView StatusLast Update
0005550Kali Linux[All Projects] Kali Package Bugpublic2019-06-17 18:10
Reportershull2805Assigned Tosteev 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005550: realtek-rtl88xxau-dkms package fails with kalli 4.14.120 armv7l for ODROID XU3, XU4
DescriptionDriver support for the Alfa AUS036ACH usb wifi adaptor is out-of-date with respect to latest kernel releases. Note that for mainstream releases, the driver package (realtek-rtl88xxau-dkms) is working fine. The issue is related to the ARM releases, specifically for the ODROID XU3 and XU4 SBCs. It appears that the driver package is looking for linux-headers from an older version of the kernel source code. Here is the output from an apt install of the driver package:

root@kali:~# apt install realtek-rtl88xxau.dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'realtek-rtl88xxau-dkms' for regex 'realtek-rtl88xxau.dkms'
The following additional packages will be installed:
  dkms
Suggested packages:
  python3-apport menu
Recommended packages:
  linux-headers-686-pae | linux-headers-amd64 | linux-headers-generic | linux-headers
The following NEW packages will be installed:
  dkms realtek-rtl88xxau-dkms
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1862 kB of archives.
After this operation, 18.0 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package dkms.
(Reading database ... 132306 files and directories currently installed.)
Preparing to unpack .../archives/dkms_2.6.1-4_all.deb ...
Unpacking dkms (2.6.1-4) ...
Selecting previously unselected package realtek-rtl88xxau-dkms.
Preparing to unpack .../realtek-rtl88xxau-dkms_5.2.20.2~20190210-0kali1_all.deb ...
Unpacking realtek-rtl88xxau-dkms (5.2.20.2~20190210-0kali1) ...
Setting up dkms (2.6.1-4) ...
Setting up realtek-rtl88xxau-dkms (5.2.20.2~20190210-0kali1) ...
Loading new realtek-rtl88xxau-5.2.20.2~20190210 DKMS files...
It is likely that 4.14.120 belongs to a chroot's host
Building for 4.14.120
Building initial module for 4.14.120
Error! Bad return status for module build on kernel: 4.14.120 (armv7l)
Consult /var/lib/dkms/realtek-rtl88xxau/5.2.20.2~20190210/build/make.log for more information.
dpkg: error processing package realtek-rtl88xxau-dkms (--configure):
 installed realtek-rtl88xxau-dkms package post-installation script subprocess returned error exit status 10
Processing triggers for man-db (2.8.5-2) ...
Errors were encountered while processing:
 realtek-rtl88xxau-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~#

Here is the make.log from the install process:
oot@kali:~#
root@kali:~# cat /var/lib/dkms/realtek-rtl88xxau/5.2.20.2~20190210/build/make.log
DKMS make.log for realtek-rtl88xxau-5.2.20.2~20190210 for kernel 4.14.120 (armv7l)
Sun Jun 16 16:09:52 UTC 2019
make ARCH=arm CROSS_COMPILE= -C /lib/modules/4.14.120/build M=/var/lib/dkms/realtek-rtl88xxau/5.2.20.2~20190210/build modules
make[1]: Entering directory '/usr/src/kernel'

  ERROR: Kernel configuration is invalid.
         include/generated/autoconf.h or include/config/auto.conf are missing.
         Run 'make oldconfig && make prepare' on kernel src to fix it.


  WARNING: Symbol version dump ./Module.symvers
           is missing; modules will have no dependencies and modversions.

  Building modules, stage 2.
scripts/Makefile.modpost:43: include/config/auto.conf: No such file or directory
make[2]: *** No rule to make target 'include/config/auto.conf'. Stop.
make[1]: *** [Makefile:1538: modules] Error 2
make[1]: Leaving directory '/usr/src/kernel'
make: *** [Makefile:1551: modules] Error 2
root@kali:~#

FYI, here is my kernel info:
root@kali:~# uname -a
Linux kali 4.14.120 0000001 SMP PREEMPT Fri May 17 19:34:41 UTC 2019 armv7l GNU/Linux
Steps To Reproduce1) Target device must be ODROID XU3 or XU4

2) Download and install the following image: https://images.offensive-security.com/arm-images/kali-linux-2019.2-odroidxu3.img.xz

2) After installing, run apt update, apt upgrade, and apt dist-upgrade to insure system is current with latest updates, fixes, features, etc

3) run apt install realtek-rtl88xxau-dkms
Additional InformationHave also downloaded and installed 2019.2 for the X86 platform. The Realtek driver installs and works perfectly in this environment.

Activities

steev

2019-06-17 03:45

developer   ~0010700

Can you try going into /usr/src/kernel and running "make modules_prepare" ?

Because of the images being cross compiled, running make modules_prepare during the image build process always resulted in incorrect binaries so we do not run it in there anymore (or shouldn't be);

If you want to be certain of it, you can run
cd /usr/src/kernel
make mrproper
make odroidxu4_defconfig
make modules_prepare

And then re-run the dkms install?

shull2805

2019-06-17 13:17

reporter   ~0010702

Thanks for the speedy response. Your suggestions were right on... the problem was fixed. You da MAN!!

Issue History

Date Modified Username Field Change
2019-06-16 18:59 shull2805 New Issue
2019-06-17 03:45 steev Note Added: 0010700
2019-06-17 13:17 shull2805 Note Added: 0010702
2019-06-17 18:10 steev Assigned To => steev
2019-06-17 18:10 steev Status new => resolved
2019-06-17 18:10 steev Resolution open => no change required