View Issue Details

IDProjectCategoryView StatusLast Update
0005620Kali Linux[All Projects] Kali Package Bugpublic2019-08-17 11:04
ReportervanguardAssigned Torhertzog 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0005620: firmware-b43legacy-installer is crashing when building kali-live
Descriptioncrash

Activities

vanguard

2019-08-07 19:08

reporter   ~0010825

When building kali-live the build is crashing, when unpacking and installing the package "firmware-b43legacy-installer".
I can not see, what is really happening, only that the build is stopping due to a problem with this package.

A normal installation on an installed kali-linux is working fine, only at building a live-system it is crashing.

This issue appeared about 3 months ago and on both architectures: i386 and amd64.

Any hints are welcome, as I am completely stuck at the moment.

Best regards

Hans

rhertzog

2019-08-15 13:45

administrator   ~0010877

Can you at least provide some logs of what you are seeing?

The daily builds are working fine and they are installing this package. This package is downloading files from the network so my suspicion is that you have some network problems in your build environment.

vanguard

2019-08-16 09:22

reporter   ~0010893

Hi Raphael,

please apologize for calling you with the wrong name in my last post. Got somehow the wrong name in my mind.

On the other hand, I do not see my last post here. So in short again:

I will test a new build at weekend, and as I am using apt-cacher-ng I will delete the named package from the repository (both , i386 and amd64)

If everything is working fine, you will be informed. If not, I will inform, too (of course), but will attach the build.log to it.

You will be stayed informed. :)

Best regards

Hans

vanguard

2019-08-16 18:15

reporter   ~0010899

Hi Raphael,

I did as I told today - and got into the same issue again. The build crashes when accessing the named package.
I saved the log and attached it. Additionally I will go on further examining.

Hope, it helps.

Best regards

Hans

build.log (1,372,136 bytes)

vanguard

2019-08-16 18:27

reporter   ~0010900

Hi Raphael,

looks like this entry in the log shows the problem

--- snip ---
A chroot environment has been detected.
Remember this firmware needs kernel >= 2.6.25.
--2019-08-16 17:26:51-- http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o
Resolving localhost (localhost)... ::1, 127.0.0.1, 127.0.0.1
Connecting to localhost (localhost)|::1|:3142... connected.
Proxy request sent, awaiting response... 403 Forbidden file type or location
2019-08-16 17:26:51 ERROR 403: Forbidden file type or location.

-- snap --

I believe, the download entry should be "https://" instead of "http://". Can you check this and try a new package with https? I would like to test this.

I tried the link manually and it automatically switches (in the browser) to https. Just an idea....

Or is there the problem, because the package wants to download out of the chroot which of course has no network itself?

Best

Hans

rhertzog

2019-08-17 11:03

administrator   ~0010902

You have all the information that you need in your log:
> Proxy request sent, awaiting response... 403 Forbidden file type or location
> 2019-08-16 17:26:51 ERROR 403: Forbidden file type or location.

You have configured an HTTP proxy and that proxy is denying you the right to download that file. Disable that proxy or reconfigure it, but it's not an issue in Kali.

Issue History

Date Modified Username Field Change
2019-08-07 19:01 vanguard New Issue
2019-08-07 19:08 vanguard Note Added: 0010825
2019-08-15 13:45 rhertzog Assigned To => rhertzog
2019-08-15 13:45 rhertzog Status new => feedback
2019-08-15 13:45 rhertzog Note Added: 0010877
2019-08-16 09:22 vanguard Note Added: 0010893
2019-08-16 09:22 vanguard Status feedback => assigned
2019-08-16 18:15 vanguard File Added: build.log
2019-08-16 18:15 vanguard Note Added: 0010899
2019-08-16 18:27 vanguard Note Added: 0010900
2019-08-17 11:03 rhertzog Note Added: 0010902
2019-08-17 11:04 rhertzog Status assigned => closed
2019-08-17 11:04 rhertzog Resolution open => no change required