View Issue Details

IDProjectCategoryView StatusLast Update
0005761Kali Linux[All Projects] Kali Package Improvementpublic2020-02-17 14:15
Reportervom Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.3 
Target VersionFixed in Version2020.2 
Summary0005761: aircrack-ng package - aircrack-ng program hangs with ctrl-c
DescriptionThe aircrack-ng package hasn't been updated since January of 2019 (in fairness, I don't believe they have had a stable release since then).

One of the most frustrating bugs in the 1.5.2 that's in Kali right now is referenced here:

https://github.com/aircrack-ng/aircrack-ng/issues/2002

With wifite for example, as wifite restarts the cracking process (example: WEP cracking) - every time it gets restarted the previous aircrack process keeps running. Eventually there are lots of these half dead processes still running in the background.

The -current aircrack has this (and man other bugs) fixed.
Steps To ReproduceRun aircrack-ng on a cap or IVs file that is not enough to crack. When aircrack says its waiting for x0000 IVs (ex: 10000 ivs) - try hitting ctrl-c. The process will hang.
Additional InformationNot suggesting that Kali pull in a -current for this on aircrack - but some kind of update would be nice since this has been broken for almost 11 months now.

Activities

vom

2020-01-25 20:45

reporter   ~0011960

1.6 was just released:

https://github.com/aircrack-ng/aircrack-ng/releases/tag/1.6

Hopefully this makes it's way into Kali soon.

rootjb0

2020-01-26 19:33

reporter   ~0011963

Will this package be included in the Kali-2020.1 release?

vom

2020-02-17 13:47

reporter   ~0012288

Looks like 1.6 was just pulled in...

https://pkg.kali.org/pkg/aircrack-ng

Issue History

Date Modified Username Field Change
2019-10-27 20:51 vom New Issue
2020-01-25 20:45 vom Note Added: 0011960
2020-01-26 19:33 rootjb0 Note Added: 0011963
2020-02-17 13:47 vom Note Added: 0012288
2020-02-17 14:15 rhertzog Assigned To => rhertzog
2020-02-17 14:15 rhertzog Status new => resolved
2020-02-17 14:15 rhertzog Resolution open => fixed
2020-02-17 14:15 rhertzog Fixed in Version => 2020.2