View Issue Details

IDProjectCategoryView StatusLast Update
0005785Kali Linux[All Projects] Tool Upgradepublic2019-11-13 13:45
Reporterkimocoder Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version 
Summary0005785: iwd needs to be updated from v0.23 to v1.0
DescriptionSome interesting reading below ..
https://lwn.net/Articles/770991/
https://www.reddit.com/r/archlinux/comments/8j6mxp/the_wpasupplicant_replacement_is_here_o/

And setup is easy too..
https://blobfolio.com/2019/10/replacing-wpa-supplicant-with-iwd-in-ubuntu-eoan/

I personally changed backend from "wpa_supplicant" to "iwd" due to some issues with wpa_supplicant and the 8812au drivers, but as the articles states,
"iwd" was/is set to take over for "wpa_supplicant" at a time. And I find "iwd" to work very well, so far.

Doesn't need to change for all Kali users at this point, just keep it up 2 date so users may choose it.

Thanks!
Additional InformationRepository is found at
https://git.kernel.org/pub/scm/network/wireless/iwd.git/

Activities

sbrun

2019-11-13 13:45

manager   ~0011297

version 1.0-1 is now in kali-rolling

Issue History

Date Modified Username Field Change
2019-11-11 15:11 kimocoder New Issue
2019-11-11 15:11 kimocoder Status new => assigned
2019-11-11 15:11 kimocoder Assigned To => sbrun
2019-11-13 13:45 sbrun Status assigned => resolved
2019-11-13 13:45 sbrun Resolution open => fixed
2019-11-13 13:45 sbrun Note Added: 0011297