View Issue Details

IDProjectCategoryView StatusLast Update
0006441Kali Linux[All Projects] General Bugpublic2020-06-13 14:24
Reportercyberpig908 Assigned Tosteev  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version2020.2 
Target VersionFixed in Version 
Summary0006441: Cannot Connect to Wireless wifi In kali Linux
DescriptionI was trying to assess my own wireless WiFi. I looked in the network connection area in the top right. It does not show any WiFi networks. I searched up some solutions with my friend, Google. I tried many commands including the following:

hello@KaliLinux:~$ sudo apt-get install kali-linux-wireless
[sudo] password for hello:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package kali-linux-wireless

hello@KaliLinux:~$ sudo iwconfig wlan0 up
iwconfig: unknown command "up"

hello@KaliLinux:~$ sudo ifconfig
eth0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
        ether 80:e8:2c:bd:a4:63 txqueuelen 1000 (Ethernet)
        RX packets 0 bytes 0 (0.0 B)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 0 bytes 0 (0.0 B)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
        inet 127.0.0.1 netmask 255.0.0.0
        inet6 ::1 prefixlen 128 scopeid 0x10<host>
        loop txqueuelen 1000 (Local Loopback)
        RX packets 8 bytes 400 (400.0 B)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 8 bytes 400 (400.0 B)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

hello@KaliLinux:~$ lsusb
Bus 002 Device 002: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Flash Drive
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0bda:b00a Realtek Semiconductor Corp. Bluetooth Radio
Bus 001 Device 002: ID 0408:5365 Quanta Computer, Inc. HP TrueVision HD Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

After all these I still cannot connect to wireless WiFi. There is no option to.
Steps To Reproduce1. On the top right there is a place were you can create connections and connect to them. There should be all the wifi you can connect to but there's not.

Activities

steev

2020-06-07 19:48

manager   ~0012893

The metapackage is called kali-tools-wireless not kali-linux-wireless - https://www.kali.org/news/major-metapackage-makeover/

Second, you're not showing any kind of wireless device, and installing random packages won't enable one. You need to know which wireless device you have, in order to use it. None of the devices listed in your lsusb output are a wireless device, one is a bluetooth device. Perhaps there is one listed via "lspci"?

You should probably read the manpage for iwconfig, as it does not include an "up" command line option.

"ifconfig" without any options will show only devices that are "up" - you'd want to run "ifconfig -a" to show all devices, or a better command is "ip a" since ifconfig is long deprecated.

cyberpig908

2020-06-08 00:20

reporter   ~0012895

Thanks. This is the result for lspci:
new@KaliLinux:~$ lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Root Complex
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 IOMMU
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:01.6 PCI bridge: Advanced Micro Devices, Inc. [AMD] Zeppelin Switch Upstream (PCIE SW.US)
00:01.7 PCI bridge: Advanced Micro Devices, Inc. [AMD] Zeppelin Switch Upstream (PCIE SW.US)
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus A
00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus B
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 5
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 6
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 7
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c4)
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
03:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) Platform Security Processor
03:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Raven2 USB 3.1
03:00.5 Multimedia controller: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor
03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
04:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 61)

I am trying to connect to a wireless router. How should I connect?

steev

2020-06-08 17:02

manager   ~0012898

So, the good news is,

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter

That's your wifi card.

The bad news is, there isn't yet a driver for that card. There was someone who was working on a driver for it, but they stopped development when they lost access to their device.

You can *try* to get https://github.com/tomaspinho/rtl8821ce working, but we can't actually do anything here. Your best bet would be to get an external card.

Issue History

Date Modified Username Field Change
2020-06-07 18:18 cyberpig908 New Issue
2020-06-07 19:48 steev Note Added: 0012893
2020-06-08 00:20 cyberpig908 Note Added: 0012895
2020-06-08 17:02 steev Assigned To => steev
2020-06-08 17:02 steev Status new => resolved
2020-06-08 17:02 steev Resolution open => not fixable
2020-06-08 17:02 steev Note Added: 0012898