View Issue Details

IDProjectCategoryView StatusLast Update
0006706Kali Linux[All Projects] Kali Package Bugpublic2020-09-20 21:08
Reportermjrarcher Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityrandom
Status assignedResolutionopen 
Product Version2020.3 
Target VersionFixed in Version 
Summary0006706: Greenbone security assistant (gsad) fail to start
DescriptionHello,
I've been able to successfully install gvm, run gvm-setup, gvm-check-setup, gvm-feed-update. After, when I try to start the services using gvm-start, gvmd.service and ospd-openvas.service start without issues, but gsad.service fails. However, when stopping the service with gvm-stop and retrying a few times, it works fine. It does not automatically open the browser saying there was an I/O error, but that can be manually opened. Another issue is with the gvm-cli command to run gmp commands. I keep getting a permission error when trying the simplest task like:
'gvm-cli socket --xml "<get_version/>". However, if I do sudo runuser -u _gvm -- gvm-cli ... it works fine. I thought 'sudo runuser -u _gvm' was supposed to be only for 'gvm-nvt-sync', which 'gvm-feed-update' does anyway. Is this how it is supposed to be?

Anyways, the 2 main bugs I wanted to report are the gsad.service failing randomly and the gvm-cli not working without having to use '_gvm' as user.
Steps To Reproducegvm-setup
gvm-check-setup
gvm-feed-update
gvm-start (1 service not running) -stopping and retrying it works.
gvm-cli socket ....(permission issue: error 13). Resolved by 'runuser -u _gvm'
Additional InformationPlease see pictures.

Activities

mjrarcher

2020-09-04 15:56

reporter  

gsad.png (322,397 bytes)
gsad2.png (211,067 bytes)
gsad2.png (211,067 bytes)
gvm-cli.png (135,058 bytes)
gvm-cli.png (135,058 bytes)

sbrun

2020-09-11 06:53

manager   ~0013413

Thanks for your report.

gvm-cli not working without having to use '_gvm' as user: yes it's how it is supposed to be. In the /usr/share/doc/gvm/README.Debian we documented that all the gvm must be use with 'sudo -u _gvm' but we didn't mention clearly the gvm-cli command. I will add this information to help other users.

For the gsad.service failing randomly I need more information. The next time it fails, please check the log /var/log/gvm/gsad and the service status ('systemctl status greenbone-security-assistant') or journalctl.

mjrarcher

2020-09-20 21:08

reporter   ~0013466

Hello,

thanks for your suggestion.
The issue has happened again, and I have included screenshots from the log and systemctl. Please see below.

gsad3.png (89,164 bytes)
gsad3.png (89,164 bytes)
gsad4.png (110,402 bytes)
gsad4.png (110,402 bytes)

Issue History

Date Modified Username Field Change
2020-09-04 15:56 mjrarcher New Issue
2020-09-04 15:56 mjrarcher File Added: gsad.png
2020-09-04 15:56 mjrarcher File Added: gsad2.png
2020-09-04 15:56 mjrarcher File Added: gvm-cli.png
2020-09-11 06:53 sbrun Assigned To => sbrun
2020-09-11 06:53 sbrun Status new => feedback
2020-09-11 06:53 sbrun Note Added: 0013413
2020-09-20 21:08 mjrarcher File Added: gsad3.png
2020-09-20 21:08 mjrarcher File Added: gsad4.png
2020-09-20 21:08 mjrarcher Note Added: 0013466
2020-09-20 21:08 mjrarcher Status feedback => assigned