View Issue Details

IDProjectCategoryView StatusLast Update
0006911Kali Linux[All Projects] General Bugpublic2021-01-12 08:03
Reporter131Curious131 Assigned Tosbrun  
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version2020.4 
Target VersionFixed in Version 
Summary0006911: System Run Away while working with GVM 20.8
DescriptionSystem run away while working with GVM 20.8 which consumes all RAM and fills up complete swap space. In this situation complete system is inaccessible.
Only hard reset would bring system out of this state.
Steps To ReproduceIn my case I have a scan with about 2500 results in a single report.
Then user should go to report page for this specific scan and switch to the results tab.
Then he must reload the page/tab several times by adding filter directives.
Reloading (i.e. adding a new filter directive) should be done while results page is still loading.
Additional InformationBug 0006763 is still there, but with GVM 20 and PostgrSQL 13.

It seems, that old database searches are still running (the page is still loading) and new searches are added to them.
After a while all system ressources are consumed from old, no longer needed searches.

I think we need an additional function which interrupts old, no longer needed searches when the specific user is starting a new search by changing filter directives.
Or, if interruption of old, no longer needed searches isn't possible, the user must not be able to do anythin new within UI until current action, i.e. the search, is finished.

Activities

kali-bugreport

2020-12-09 18:26

reporter   ~0013959

Duplicate of: 0006907

Issue History

Date Modified Username Field Change
2020-12-06 20:12 131Curious131 New Issue
2020-12-06 20:12 131Curious131 Issue generated from: 0006907
2020-12-09 18:26 kali-bugreport Note Added: 0013959
2021-01-12 08:03 sbrun Assigned To => sbrun
2021-01-12 08:03 sbrun Status new => closed
2021-01-12 08:03 sbrun Resolution open => duplicate