View Issue Details

IDProjectCategoryView StatusLast Update
0006974Kali Linux[All Projects] Feature Requestspublic2021-01-06 08:32
Reporterjmg Assigned Todaniruiz  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2020.4 
Target VersionFixed in Version2021.1 
Summary0006974: Better ZSH support for virtual environments
DescriptionThe ZSH terminal doesn't look very good with a python virtual environment. It would be great if better support could be added for virtual environments. Currently, when you activate a venv, the terminal kind of looks broken.
Steps To Reproduce0. If you don't have "python3-venv" installed, run "sudo apt install python3-venv"
1. Open a terminal window.
2. Create a venv: "python3 -m venv venv"
3. Activate the venv: "source ./venv/bin/activate"
4. Notice that the terminal looks kinda broken like in the screenshot. Longer venv names would look even more broken.
Additional InformationWithout the venv, the prompt currently looks like this: (kali@kali)-[~]

I was thinking the venv could go just before the username like this: ((venv) kali@kali)-[~]

If someone can point me to the git repo for the ZSH theme, I'd actually be willing to submit a PR for this, but I wanted to see if there's any interest first. If anyone has a better suggestion about where the venv could go, please suggest :)

Activities

jmg

2021-01-04 06:20

reporter  

daniruiz

2021-01-04 07:18

developer   ~0014029

You can find the .zshrc file inside our gitlab repository https://gitlab.com/kalilinux/packages/kali-defaults/-/blob/kali/master/etc/skel/.zshrc
Feel free to open a PR with the suggested changes ;)

jmg

2021-01-04 09:00

reporter   ~0014030

Thanks @daniruiz. I will create a gitlab account and try to handle it this week.

jmg

2021-01-04 16:30

reporter   ~0014032

@daniruiz - I went ahead and implemented a few different options. I opened an issue on the GitLab repo if you'd like to vote for one of the options (or suggest a different one).

https://gitlab.com/kalilinux/packages/kali-defaults/-/issues/5

jmg

2021-01-04 20:30

reporter   ~0014033

@daniruiz - Opened a merge request:
https://gitlab.com/kalilinux/packages/kali-defaults/-/merge_requests/6

daniruiz

2021-01-06 08:31

developer   ~0014040

Merged!
Thanks again ;)

Issue History

Date Modified Username Field Change
2021-01-04 06:20 jmg New Issue
2021-01-04 06:20 jmg File Added: Screen Shot 2021-01-03 at 10.09.50 PM.png
2021-01-04 07:14 daniruiz Assigned To => daniruiz
2021-01-04 07:14 daniruiz Status new => assigned
2021-01-04 07:18 daniruiz Note Added: 0014029
2021-01-04 09:00 jmg Note Added: 0014030
2021-01-04 16:30 jmg Note Added: 0014032
2021-01-04 20:30 jmg Note Added: 0014033
2021-01-06 08:31 daniruiz Note Added: 0014040
2021-01-06 08:32 daniruiz Status assigned => resolved
2021-01-06 08:32 daniruiz Resolution open => fixed
2021-01-06 08:32 daniruiz Fixed in Version => 2021.1