View Issue Details

IDProjectCategoryView StatusLast Update
0007444Kali Linux[All Projects] Kali Package Bugpublic2021-11-19 08:08
Reporterfbeltrao Assigned Tosbrun  
PrioritynormalSeveritytweakReproducibilityunable to reproduce
Status assignedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0007444: faraday and empire powershell
DescriptionI cannot update faraday and empire powershell packages, screenshot below

Activities

fbeltrao

2021-11-15 14:49

reporter  

error (4,621 bytes)
┌──(kali㉿kali)-[~]
└─$ sudo apt upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up powershell-empire (4.2.0-0kali1) ...
[*] Loading default config
[>] Would you like to reset your Empire instance? [y/N]: [*] Setting up database.
[*] Adding default user.
[*] Adding database config.
[*] Generating random staging key
[*] Adding default bypasses.
[*] Adding default keyword obfuscation functions.
Traceback (most recent call last):
  File "/usr/share/powershell-empire/empire.py", line 11, in <module>
    import empire.server.server as server
  File "/usr/share/powershell-empire/empire/server/server.py", line 41, in <module>
    from empire.server.common import empire, helpers
  File "/usr/share/powershell-empire/empire/server/common/empire.py", line 41, in <module>
    from prompt_toolkit import PromptSession, HTML
ImportError: cannot import name 'PromptSession' from 'prompt_toolkit' (/usr/local/lib/python3.9/dist-packages/prompt_toolkit-1.0.14-py3.9.egg/prompt_toolkit/__init__.py)
dpkg: error processing package powershell-empire (--configure):
 installed powershell-empire package post-installation script subprocess returned error exit status 1
Setting up faraday (3.17.1-0kali2) ...
Traceback (most recent call last):
  File "/usr/bin/faraday-manage", line 33, in <module>
    sys.exit(load_entry_point('faradaysec==3.17.1', 'console_scripts', 'faraday-manage')())
  File "/usr/bin/faraday-manage", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 850, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3/dist-packages/faraday/manage.py", line 38, in <module>
    from pgcli.main import PGCli
  File "/usr/lib/python3/dist-packages/pgcli/main.py", line 36, in <module>
    from prompt_toolkit.completion import DynamicCompleter, ThreadedCompleter
ImportError: cannot import name 'DynamicCompleter' from 'prompt_toolkit.completion' (/usr/local/lib/python3.9/dist-packages/prompt_toolkit-1.0.14-py3.9.egg/prompt_toolkit/completion.py)
dpkg: error processing package faraday (--configure):
 installed faraday package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 powershell-empire
 faraday
E: Sub-process /usr/bin/dpkg returned an error code (1)
                                                                                  
┌──(kali㉿kali)-[~]
└─$ >....                                                                         
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 850, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3/dist-packages/faraday/manage.py", line 38, in <module>
    from pgcli.main import PGCli
  File "/usr/lib/python3/dist-packages/pgcli/main.py", line 36, in <module>
    from prompt_toolkit.completion import DynamicCompleter, ThreadedCompleter
ImportError: cannot import name 'DynamicCompleter' from 'prompt_toolkit.completion' (/usr/local/lib/python3.9/dist-packages/prompt_toolkit-1.0.14-py3.9.egg/prompt_toolkit/completion.py)
dpkg: error processing package faraday (--configure):
 installed faraday package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 powershell-empire
 faraday
E: Sub-process /usr/bin/dpkg returned an error code (1)

error (4,621 bytes)

sbrun

2021-11-19 08:08

manager   ~0015435

Thanks for the report.

It seems you have an old version of prompt_toolkit Python module installed in /usr/local/lib/python3.9/dist-packages/. It's something you installed manually. The Kali packages do not install anything in /usr/local.

You need to remove this. Then Python will import the correct version of prompt_toolkit (in /usr/lib/python3/dist-packages/)

Issue History

Date Modified Username Field Change
2021-11-15 14:49 fbeltrao New Issue
2021-11-15 14:49 fbeltrao File Added: error
2021-11-19 07:55 sbrun Assigned To => sbrun
2021-11-19 07:55 sbrun Status new => assigned
2021-11-19 08:08 sbrun Note Added: 0015435