View Issue Details

IDProjectCategoryView StatusLast Update
0007602Kali Linux[All Projects] General Bugpublic2022-02-28 07:24
Reportermax06 Assigned Todaniruiz  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version2022.1 
Target VersionFixed in Version 
Summary0007602: Popping Balloons (in 2022.1)
DescriptionA default Kali installation (or the live cd) in a virtual machine on hyper-v starts eating up all available memory shortly after logging in into xfce.
The consumption only shows in the hyper-v console, not in the guest itself.
It stops when the max. configured memory is reached. This might be 1TB of ram on a fresh vm without configuration changes, which basically breaks everything. Dynamic memory needs to be enabled for this (by default).
Steps To ReproduceCreate a new Hyper-V VM. (Recommendation: Don't use quick create.)
I went with
 - Generation 2
 - 1GB initial memory with dynamic memory active
 - the default switch
 - a new Harddrive (5Gb) which won't be used
 - and the kali live cd image as boot device

You can also install Kali with the default options, it won't change the result.

Before you start the instance: Edit its properties, disable secure boot and set a reasonable memory limit (16Gb here).

Watch the memory tab in the hyper-v manager once the instance booted. It might take 2-3 minutes for the data to show up. You won't see the consumed memory in the guest itself.

If the issue is reproducable: The memory balloon with grow and ultimately block your system once swapping starts.
Additional InformationWhen you run the instance without configuring a lower memory limit (overprovisioning), it will eventually create log entries about unhandled hv_ballooning events. Those happen so rapidly, they wrote 70GB of logs here in less than 20 minutes.

I tested the same scenario with an ubuntu live cd, it doesn't happen there. Also the rate of updates about the memory usage for the hypervisor is way faster, like one per second. With kali, it's something between 30s and a minute.

The effect only starts after being logged in. There's no difference if it's the regular console of the extended thingie with xrdp. Logging out/closing the console has no effect.

Relationships

duplicate of 0007552 assignedsbrun Popping Balloons 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2022-02-27 21:25 max06 New Issue
2022-02-27 21:25 max06 Issue generated from: 0007552
2022-02-27 21:25 max06 Relationship added related to 0007552
2022-02-28 07:24 daniruiz Assigned To => daniruiz
2022-02-28 07:24 daniruiz Status new => closed
2022-02-28 07:24 daniruiz Resolution open => duplicate
2022-02-28 07:24 daniruiz Relationship replaced duplicate of 0007552