View Issue Details

IDProjectCategoryView StatusLast Update
0007633Kali LinuxGeneral Bugpublic2022-03-23 10:30
Reporterkzb Assigned Todaniruiz  
Status resolvedResolutionfixed 
Product Version2022.1 
Summary0007633: enum4linux doesn't work anymore even with provided fixes and updates (btw enum4linux is outdated on Kali)


well, we have a serious issue with enum4linux and smbclient. When you try to scan older SMBs e.g. for OSCP in PWK Labs it will show various errors.

Enum4Linux shows a stack of errors regarding undefined variables and smbclient show a lot of errors and that it wasn't able to grab anything from the SMBs, despite it could login to the SMB and so on.

I searched the whole internet (fr) to find a solution and tried to fiddle around with it, does anyone of you have a bugfix? In Kali Forums it's mentioned but nobody replied to that question by a different user.

BTW: enum4linux in the Kali Repo is outdated, I tried to replace it, to at least hide the errors with the Cisco enum4linux in a repo.

I got the Kali from the Website, it's even the one recommended in PWK (btw).

Sorry for bad explanation, I still have no clue wtf is going on here.

Steps To Reproduce

enum4linux <yourtarget> or smbclient (-N) -L <yourtarget>

you'll see a lot of errors, especially being said in the file. It won't let you run OS detection and various other steps, which are done with smbclient, which doesn't work either...

Example: Use of uninitialized value $os_info in concatenation (.) or string at ./ line 464

Additional Information

Steps already tried:

  • reconfiguration of smbclient to lower versions (NT1, CORE) in /etc/samba/smb.conf
  • updating kali && upgrading
  • try to purge and reinstall smbclient and enum4linux
  • upgrading enum4linux manually (CISCO repo, works partially)

Not tried:

  • using a older Kali version (but WTF?)




2022-03-18 22:53

manager   ~0015906

I was unable to reproduce this issue using a fresh Kali install and kali-tweaks' wide compatibility mode for samba. The enum4linux package has been upgraded now, so it should be able to be updated in the next day or so.



2022-03-20 02:29

reporter   ~0015913

Seems fixed // FYI Public



2022-03-21 08:38

manager   ~0015914

Glad it got fixed. I'm closing this then

Anyway I've seen you mentioned you updated the system with apt clean, which is a command that doesn't update the system but clean all cached deb packages. So just in case here is the documentation for updating Kali.



2022-03-23 09:02

reporter   ~0015931

Litte info: Mirrors seem updated now! Thanks for the little reminder about apt clean! My text was not well written. Don't worry I am fully aware that apt clean removes the cached deb packs from the system. The idea behind that step was, to avoid wrongly cached packs, despite the filenames of the new and old deb of enum4linux differ. Sorry for that confusion and again thanks for the clarification.

Issue History

Date Modified Username Field Change
2022-03-18 02:16 kzb New Issue
2022-03-18 22:53 Gamb1t Note Added: 0015906
2022-03-20 02:29 kzb Note Added: 0015913
2022-03-21 08:38 daniruiz Note Added: 0015914
2022-03-21 08:38 daniruiz Assigned To => daniruiz
2022-03-21 08:38 daniruiz Status new => closed
2022-03-21 08:38 daniruiz Resolution open => no change required
2022-03-23 09:02 kzb Status closed => feedback
2022-03-23 09:02 kzb Resolution no change required => reopened
2022-03-23 09:02 kzb Note Added: 0015931
2022-03-23 10:30 daniruiz Status feedback => resolved
2022-03-23 10:30 daniruiz Resolution reopened => fixed