View Issue Details

IDProjectCategoryView StatusLast Update
0007637Kali LinuxKali Package Bugpublic2022-03-29 20:09
Reporterjdkelly156 Assigned Tosteev  
Status resolvedResolutionfixed 
Product Version2022.1 
Fixed in Version2022.2 
Summary0007637: 5-16-0-kali5-arm64 update issue

I have a parallels virtual machine running Kali Linux 5.16.0-kali1-arm64 on my MacBook Pro M1. I initiated an update was able to run apt update, upgrade, and dist-upgrade with no errors. However, on reboot, 5.16.0-kali5-arm64 fails to boot past loading the initial ramdisk. I reverted my image and re-did my update and still ran into the same issue.

Steps To Reproduce

From 5.16.0-kali1-arm64 run normal sudo apt update, upgrade, and dits-upgrade commands and reboot. Upon reboot to 5.16.0-kali5-arm64 booting stops at loading the initial ramdisk.

I also was able to try to boot into recovery mode and I still have the same issue.

Additional Information

Please note:

  • MacBook Pro M1
    Mac OS 12.3 (21E230)

  • Parallels
    Version 17.1.1 (51537)

Kali 5.16.0-kali1-arm64 to 5.16.0-kali5-arm64

The image I uploaded below is the error I receive when I try to boot into recovery mode.

I have no issues with 5.16.0-kali1-arm64.

I am only having issues with 5.16.0-kali5-arm64 booting past EFI.

Thank you for any help.

Attached Files




2022-03-21 18:59

manager   ~0015916

Can you try removing "quiet splash" from the kernel command line arguments in grub and add "verbose" ?



2022-03-21 19:00

reporter   ~0015917

Yup. I will do it now.



2022-03-21 19:17

reporter   ~0015918

I went into the grub options and changed quiet splash to verbose but I got the same error results as the recovery mode. Images attached as proof.



2022-03-21 19:37

manager   ~0015919

I'm seeing the same issue here, I'm updating my VMWare install just to test if it's an issue in Parallels or with the kernel itself.



2022-03-21 19:40

manager   ~0015920

We do keep older kernels installed, so you should be able to choose an older kernel from the advanced menu, as a workaround, for now.



2022-03-21 19:54

manager   ~0015921

VMware Fusion shows the exact same issue.

Actual hardware (Pinebook Pro) does not have the issue. It could be due to an EFI change in the kernel version, I will have to look over the changes from kali4-kali5 to check.



2022-03-21 20:15

manager   ~0015922

I'm still not entirely sure if the bug is in the kernel itself, or in the virtualization softwares, but when I add more to the kernel command line (console=efifb earlyconsole=efifb efi=debug) I end up with:

efibug.png (29,772 bytes)   
efibug.png (29,772 bytes)   


2022-03-21 20:24

manager   ~0015923

Upstream mailing list issue[email protected]/ - this appears to be a hypervisor issue, so we likely need to contact Parallels and VMWare about this. Looks like it is the back ported fixes for Spectre v2 mitigations that is causing the issue.



2022-03-21 20:39

manager   ~0015924

Based on a read through the thread, as well as the linked QEMU issue, this will be hitting Parallels, VMware Fusion as well as UTM (based on QEMU), until they all update (QEMU update is possibly available already?) due to no ID register is allowed to be undefined (UNDEF).



2022-03-23 02:11

reporter   ~0015927

I was also experiencing this issue - running macOS Monterey 12.3 on a MacBook Pro with M1 Max so kali ARM VM in Parallels. Ended up blocking the linux-image-arm64 and linux-headers-arm64 packages from updating as a workaround. I just updated to Parallels 17.1.2 and ran a dist-upgrade, bringing the kernel to linux-image-5.16.0-kali5-arm64 / 5.16.14-1kali1. It worked fine with no more hang after "Loading initial ramdisk", so one of those two changes must have addressed the problem.

The changelog for Parallels does not specifically state that it fixed this issue, but does say the update "addresses overall stability and performance issues."

Good enough!



2022-03-23 02:19

reporter   ~0015928

If it helps anyone, here are notes for reference on holding back those two packages as a workaround but letting everything else update. I attached it as an image because the DPI on the firewall for this bug tracker seems to think these notes are an exploit when they are included in-line or as a text attachment.

hold back kernel.png (243,754 bytes)   
hold back kernel.png (243,754 bytes)   


2022-03-23 16:48

manager   ~0015932

We do have a kernel package in the kali-experimental repository with the 3 commits that cause this breakage removed, however, with 17.1.2 of Parallels, you should be okay now. Unfortunately, we're still waiting for a fixed version for VMware Fusion.

We won't be carrying these reverts forever, so hopefully they have a new release soon. I'll try pinging the VMware person I know on Twitter and see if we can get a response.



2022-03-29 20:09

manager   ~0015973

We have added linux-image-5.16.0-kali6 to the kali-rolling repositories which has the patches reverted, so this bug is now resolved. Thanks for the report!

Issue History

Date Modified Username Field Change
2022-03-21 18:58 jdkelly156 New Issue
2022-03-21 18:58 jdkelly156 File Added: Screen Shot 2022-03-21 at 14.55.17.png
2022-03-21 18:59 steev Note Added: 0015916
2022-03-21 19:00 jdkelly156 Note Added: 0015917
2022-03-21 19:17 jdkelly156 File Added: Screen Shot 2022-03-21 at 15.13.57.jpg
2022-03-21 19:17 jdkelly156 File Added: Screen Shot 2022-03-21 at 15.14.22.jpg
2022-03-21 19:17 jdkelly156 File Added: Screen Shot 2022-03-21 at 15.13.28.jpg
2022-03-21 19:17 jdkelly156 Note Added: 0015918
2022-03-21 19:37 steev Note Added: 0015919
2022-03-21 19:40 steev Note Added: 0015920
2022-03-21 19:54 steev Note Added: 0015921
2022-03-21 20:15 steev File Added: efibug.png
2022-03-21 20:15 steev Note Added: 0015922
2022-03-21 20:24 steev Note Added: 0015923
2022-03-21 20:39 steev Note Added: 0015924
2022-03-23 02:11 modemlaugh Note Added: 0015927
2022-03-23 02:19 modemlaugh File Added: hold back kernel.png
2022-03-23 02:19 modemlaugh Note Added: 0015928
2022-03-23 16:48 steev Note Added: 0015932
2022-03-29 20:09 steev Assigned To => steev
2022-03-29 20:09 steev Status new => resolved
2022-03-29 20:09 steev Resolution open => fixed
2022-03-29 20:09 steev Fixed in Version => 2022.2
2022-03-29 20:09 steev Note Added: 0015973