View Issue Details

IDProjectCategoryView StatusLast Update
0008254Kali LinuxGeneral Bugpublic2023-04-12 06:18
Reportercool-GT-X Assigned Toarnaudr  
PriorityhighSeverityminorReproducibilityunable to reproduce
Status closedResolutionduplicate 
Product Version2023.1 
Summary0008254: No sound on kali 2023.1
Description

I am using Linux 6.1.0-kali7-amd64 kernel - Debian release and tried everything but still no sound after the upgrade.

Relationships

duplicate of 0008250 resolvedarnaudr No sound on kali 2023.1 

Activities

adhamhaddad

adhamhaddad

2023-04-06 13:16

reporter  

arnaudr

arnaudr

2023-04-07 01:22

manager   ~0017770

You don't have pipewire-pulse running, which is strange. Can you please make sure to update your system, install pipewire-pulse, then reboot? That is:

<pre>
sudo apt update
sudo apt full-upgrade
sudo apt install -y pipewire-pulse
</pre>

Then reboot, run « ps -fp $(pgrep wire) » and check that pipewire-pulse is up and running. If it's not, please run « systemctl --user status -n 100 pipewire-pulse » and paste the output here. Thanks!

arnaudr

arnaudr

2023-04-07 01:24

manager   ~0017771

Oh, wait, are you logged in as root? I didn't check this scenario. Maybe that's the issue.

adhamhaddad

adhamhaddad

2023-04-07 01:36

reporter   ~0017772

is there a solution?

arnaudr

arnaudr

2023-04-07 01:44

manager   ~0017773

Can you try the steps outlined above and tell me if it works?

adhamhaddad

adhamhaddad

2023-04-07 01:53

reporter   ~0017774

It works, thank you.

adhamhaddad

adhamhaddad

2023-04-07 02:02

reporter   ~0017775

Okay, the problem was issued before and the solution was to remove the pipewire-pulse package, It works before but after this update, it needs to be re-install the package again

arnaudr

arnaudr

2023-04-07 03:17

manager   ~0017776

Yep correct, from now on the package pipewire-pulse needs to be installed. This page ("no sound on Kali 2022.3") is now archived and is misleading.

I will fix the kali-desktop-xfce metapackage to make it a harder requirement to have pipewire-pulse installed. I didn't realize that apt would not install it if you manually removed it beforehand.

kali-bugreport

kali-bugreport

2023-04-12 04:39

reporter   ~0017791

Yet another wrongly cloned issue...

Duplicate of 0008250

Issue History

Date Modified Username Field Change
2023-04-07 16:09 cool-GT-X New Issue
2023-04-07 16:09 cool-GT-X Issue generated from: 0008250
2023-04-12 04:39 kali-bugreport Note Added: 0017791
2023-04-12 06:18 arnaudr Assigned To => arnaudr
2023-04-12 06:18 arnaudr Status new => closed
2023-04-12 06:18 arnaudr Resolution open => duplicate
2023-04-12 06:18 arnaudr Relationship added duplicate of 0008250