View Issue Details

IDProjectCategoryView StatusLast Update
0008764Kali LinuxGeneral Bugpublic2024-05-24 05:47
Reporterdiazela Assigned Tosteev  
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionopen 
Summary0008764: System Freezes During Update, Kernel Panic on Boot

While performing a system update on my Kali which is installed as main OS, the update process froze. I waited for some time, but the system remained unresponsive, so I had to forcefully power off the PC by holding the power button.

Upon rebooting, the system got stuck on the Kali Linux logo screen. Attempting to boot into recovery mode resulted in a kernel panic with the following error message:

Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00
CPU: 1 PID: 1 Comm: init Not tainted 6.6.9-amd64 0000001

I tried booting from a Kali Live USB to troubleshoot and recover the system. My first attempt were completely messed up, and didn't recognize APT nor EXT4 filesystems. At this step my partitions were:


I tried to fix it using superblock backup to remount the partitions, which resulted in another kernel panic, so i will not enumerate these steps.

I rebooted again on Kali Live and used the MEMTEST66 utilities to check the memory, which showed no errors at all.

I rebooted again into Live and choose normal boot, and saw my partitions changed to:


Here are the steps I took from there and I got to work.

list your partitions


Create mount points

mkdir -p /mnt/kali
mkdir -p /mnt/kali/dev
mkdir -p /mnt/kali/proc
mkdir -p /mnt/kali/sys
mkdir -p /mnt/kali/run

Mount the root partition

mount /dev/sda1 /mnt/kali

Verify contents

ls /mnt/kali

Mount filesystems

mount --bind /dev /mnt/kali/dev
mount --bind /proc /mnt/kali/proc
mount --bind /sys /mnt/kali/sys
mount --bind /run /mnt/kali/run

Chroot into the partition

chroot /mnt/kali


apt update

Reconfigure locales

dpkg-reconfigure locales

Install firmware packages

apt install firmware-misc-nonfree


apt upgrade

Fix broken dependencies

apt --fix-broken install

Rebuild initramfs

update-initramfs -u -k all

Exit chroot and unmount filesystems

umount /mnt/kali/dev
umount /mnt/kali/proc
umount /mnt/kali/sys
umount /mnt/kali/run
umount /mnt/kali

Reboot on your main system





2024-05-20 15:32

manager   ~0019316

Are you saying you were able to get this working in the end?



2024-05-21 08:08

reporter   ~0019323

Yes I've been able to fix it. But so far I found at least 2 others to who happened exactly the same.



2024-05-21 16:12

manager   ~0019324

Unfortunately, neither you, nor the person you linked have posted what type of hardware you're on. We haven't reproduced this here in our testing.



2024-05-24 05:47

reporter   ~0019332

Kali Linux 2024.1 / 64-bit / Installer iso / KDE

Model name: Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz
BIOS Model name: Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz To Be Filled By O.E.M. CPU @ 2.4GHz
Manufacturer: Dell Inc.
Product Name: 0K4CNR
VGA: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
Mem: 15Gi
Swap: 975Mi
Ethernet: Intel Corporation Ethernet Connection I219-LM (rev 21)
Network: Intel Corporation Wireless 8260 (rev 3a)

Issue History

Date Modified Username Field Change
2024-05-20 08:49 diazela New Issue
2024-05-20 15:31 steev Assigned To => steev
2024-05-20 15:31 steev Status new => assigned
2024-05-20 15:32 steev Note Added: 0019316
2024-05-21 08:08 diazela Note Added: 0019323
2024-05-21 16:12 steev Note Added: 0019324
2024-05-24 05:47 diazela Note Added: 0019332