View Issue Details

IDProjectCategoryView StatusLast Update
0000887Kali Linux[All Projects] Kali Package Bugpublic2016-06-24 12:47
ReporterAl3xG Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2016.1 
Summary0000887: Dradis shortcut in kali menu don't work
DescriptionIf Dradis is started from Application > Kali Linux > System Services > Dradis > dradis start, it throws the following error:

Rails Error: Unable to access log file. Please ensure that /usr/lib/dradis/server/log/production.log exists and is chmod 0666. The log level has been raised to WARN and the output directed to STDERR until the problem is fixed.

If I run /usr/lib/dradis/start.sh, Dradis starts correctly.

Activities

Al3xG

2014-01-15 17:12

reporter   ~0001406

Last edited: 2014-01-15 17:12

View 2 revisions

Seems a permission problem, because running dradis as service means that the program is executed with dradis user instead of root user.
The issue can be resolved with the following commands:

chown -R dradis:dradis /var/lib/dradis/tmp

chmod 666 /var/log/dradis/production.log

sbrun

2016-06-24 12:47

manager   ~0005418

it works nowadays

Issue History

Date Modified Username Field Change
2014-01-09 16:37 Al3xG New Issue
2014-01-15 17:12 Al3xG Note Added: 0001406
2014-01-15 17:12 Al3xG Note Edited: 0001406 View Revisions
2016-06-24 12:47 sbrun Note Added: 0005418
2016-06-24 12:47 sbrun Status new => resolved
2016-06-24 12:47 sbrun Resolution open => fixed
2016-06-24 12:47 sbrun Fixed in Version => 2016.1