Relationship Graph

Relationship Graph
related to related to child of child of duplicate of duplicate of

View Issue Details

IDProjectCategoryView StatusLast Update
0006897Kali LinuxGeneral Bugpublic2021-06-24 01:58
ReporterNewUserTim Assigned Tosteev  
Status resolvedResolutionno change required 
Product Version2020.4 
Summary0006897: Intel(R) Dual Band Wireless-AC 3165 unstable when power management turned on

I am a new linux user, and I'm sure this issue has been noted here.(at least it should have been) but I can't find it if it is. I've been ALL over the internet trying to find a fix for this. Apparently a lot of people have this same issue. I have yet to find a solution.

wireless card: Intel(R) Dual Band Wireless-AC 3165
problem: sometimes it reads the card and the wifi works, other times it does not. sometimes a reboot remedies the issue, sometimes it doesn't. Apparently from what I read this is a common problem with this type of card. If it reads the card and works fine for a day or two, then after a reboot it starts again. It might work for the first 3 minutes after startup, then goes down. It says its connected but isn't. after about 5 minutes it fails to show any connection at all.

I get this error: failed to wake nic for hcmd

Ive tried ip link set wlan0 down/up, and just about every other suggestion i could find. doesn't work. I get an input/output error.

I've tried just about every thing I can find listed about this. Nothing has worked.

I dual boot kali with windows 10. it's not a hardware problem, as it reads it sometimes and for a few minutes after i reboot. and the card works fine with windows. i installed the correct drivers and still the issue persists. Has anyone found a remedy for this or is this a true bug?

Steps To Reproduce

Randomly happens. Not sure how to sure-fire reproduce it.


has duplicate 0006914 resolvedsteev Problem with wifi on dual-boot. 




2021-01-30 01:43

reporter   ~0014172

I actually figured out what the problem was. for some reason, the wifi power management is turned on. When i Turned it off i had 0 issue. So I did the following.

iwconfig wlan0

wlan0 IEEE 802.11 ESSID:
Mode:Managed Frequency:5.26 GHz
Bit Rate=6 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on <-------
Link Quality=56/70 Signal level=-54 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:3 Missed beacon:0

Create this file, if you did not have it before.

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

The content of the file:

wifi.powersave = 2


NM_SETTING_WIRELESS_POWERSAVE_IGNORE (1): don't touch existing setting



Then I restarted NetworkManager (sudo systemctl restart NetworkManager)

Hope this helps someone else. I see people all over the place having my same problem. This worked for me. Not saying it will work for everyone.

If there is a duplicate issue/fix I apologize. I have not seen it.



2021-06-24 01:58

manager   ~0014824

I've updated the summary so that this can be found by others if they are having a similar issue with the same chipset. Glad to hear you got it sorted out.

Issue History

Date Modified Username Field Change
2020-12-03 07:33 NewUserTim New Issue
2020-12-06 20:12 131Curious131 Issue cloned: 0006914
2021-01-30 01:43 NewUserTim Note Added: 0014172
2021-06-24 01:55 steev Relationship added has duplicate 0006914
2021-06-24 01:57 steev Summary Problem with wifi on dual-boot. => Intel(R) Dual Band Wireless-AC 3165 unstable when power management turned on
2021-06-24 01:58 steev Assigned To => steev
2021-06-24 01:58 steev Status new => resolved
2021-06-24 01:58 steev Resolution open => no change required
2021-06-24 01:58 steev Note Added: 0014824