View Issue Details

IDProjectCategoryView StatusLast Update
0001290Kali Linux[All Projects] Kali Package Bugpublic2014-05-28 07:50
Reportertrifid Assigned Torhertzog  
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version1.0.7 
Target VersionFixed in Version1.0.8 
Summary0001290: kali 1.0.7 fails to build with fglrx
DescriptionAfter doing a apt-get dist-upgrade flgrx failed to build in x64.
Steps To ReproduceNot sure if reproducible this is the only kali system i have on x64 that runs an amd card. I have tried a apt-get purge fglrx* and full reinstall of kernel headers etc. I have also tried to purge all related pacakges and do the bugfix for 1.0.6 described here http://www.blackmoreops.com/2014/03/05/install-amd-ati-proprietary-fglrx-driver-kali-linux-1-0-6/ .
Additional InformationWhere build failed

Reading state information... Done
The following packages were automatically installed and are no longer required:
  diffstat libmozjs22d linux-kbuild-3.12 linux-kbuild-3.7 openjdk-7-jre-lib python-apsw python-utidylib xulrunner-22.0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/438 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 389081 files and directories currently installed.)
Preparing to replace linux-headers-3.14-kali1-amd64 3.14.4-1kali1 (using .../linux-headers-3.14-kali1-amd64_3.14.4-1kali1_amd64.deb) ...
Unpacking replacement linux-headers-3.14-kali1-amd64 ...
Setting up linux-headers-3.14-kali1-amd64 (3.14.4-1kali1) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.14-kali1-amd64
Error! Bad return status for module build on kernel: 3.14-kali1-amd64 (x86_64)
Consult /var/lib/dkms/fglrx/13.12/build/make.log for more information.


|\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\|
contents of /var/lib/dkms/fglrx/13.12/build/make.log


make: Entering directory `/usr/src/linux-headers-3.14-kali1-amd64'
  LD /var/lib/dkms/fglrx/13.12/build/built-in.o
  CC [M] /var/lib/dkms/fglrx/13.12/build/firegl_public.o
/var/lib/dkms/fglrx/13.12/build/firegl_public.c: In function ‘KCL_GetEffectiveUid’:
/var/lib/dkms/fglrx/13.12/build/firegl_public.c:1761:5: error: incompatible types when returning type ‘kuid_t’ but ‘KCL_TYPE_Uid’ was expected
/var/lib/dkms/fglrx/13.12/build/firegl_public.c:1766:1: warning: control reaches end of non-void function [-Wreturn-type]
make[3]: *** [/var/lib/dkms/fglrx/13.12/build/firegl_public.o] Error 1
make[2]: *** [_module_/var/lib/dkms/fglrx/13.12/build] Error 2
make[1]: *** [sub-make] Error 2
make: *** [all] Error 2
make: Leaving directory `/usr/src/linux-headers-3.14-kali1-amd64'



Activities

trifid

2014-05-28 03:47

reporter   ~0001922

well as it turns out the 3.14 kernel only supports fglrx version 14.4-2... http://metadata.ftp-master.debian.org/changelogs/non-free/f/fglrx-driver/unstable_changelog

rhertzog

2014-05-28 07:50

administrator   ~0001924

Uploaded fglrx-driver_14.4.2-1kali1.dsc to kali-proposed-updates to fix this.

Issue History

Date Modified Username Field Change
2014-05-28 03:08 trifid New Issue
2014-05-28 03:47 trifid Note Added: 0001922
2014-05-28 07:50 rhertzog Note Added: 0001924
2014-05-28 07:50 rhertzog Status new => resolved
2014-05-28 07:50 rhertzog Fixed in Version => 1.0.8
2014-05-28 07:50 rhertzog Resolution open => fixed
2014-05-28 07:50 rhertzog Assigned To => rhertzog
2014-07-29 16:43 aniketbhole Issue cloned: 0001634