View Issue Details

IDProjectCategoryView StatusLast Update
0001328Kali Linux[All Projects] General Bugpublic2014-06-04 15:09
Reporterddos Assigned Tomuts  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.0.7 
Target VersionFixed in Version 
Summary0001328: w3af not working (was pip install pyOpenSSL=0.13.1)
Descriptionwhen i ran w3af_console on terminal, i was required to install pyOpenSSL=0.13.1. Then i tried to install pyOpenSSL=0.13.1, but it was not completed.

Activities

ddos

2014-06-04 08:08

reporter  

Screenshot from 2014-06-04 15:09:51.png (797,253 bytes)

muts

2014-06-04 08:21

administrator   ~0001982

Last edited: 2014-06-04 09:52

View 3 revisions

w3af works out of the box in Kali 1.0.7 without any additional dependencies needed.
Unless you can better describe your issue, we can't help. (http://docs.kali.org/troubleshooting/submitting-issues-kali-bug-tracker)

ddos

2014-06-04 09:20

reporter   ~0001984

Last edited: 2014-06-04 09:20

View 2 revisions

here is my issue...

https://www.youtube.com/watch?v=16xny4mT9DA&feature=youtu.be

thanks!

muts

2014-06-04 09:31

administrator   ~0001985

Last edited: 2014-06-04 09:56

View 3 revisions

My bad. Further testing this in a clean chroot environment confirms the same bug. All the dependencies exist in Kali, however the w3af dependency_check is failing and aborting.

Please note:
1) You shouldn't be using pip to install python dependencies in Kali.
2) Youtube videos are not the recommended way to convey bug reports.

muts

2014-06-04 15:09

administrator   ~0001995

Removed unneeded dependency check. This should now be resolved in w3af_1.6.0.2-0kali3, and uploaded to the main repos soon.

Issue History

Date Modified Username Field Change
2014-06-04 08:08 ddos New Issue
2014-06-04 08:08 ddos File Added: Screenshot from 2014-06-04 15:09:51.png
2014-06-04 08:21 muts Note Added: 0001982
2014-06-04 08:21 muts Status new => closed
2014-06-04 08:21 muts Assigned To => muts
2014-06-04 08:21 muts Resolution open => unable to reproduce
2014-06-04 08:21 muts Note Edited: 0001982 View Revisions
2014-06-04 09:20 ddos Note Added: 0001984
2014-06-04 09:20 ddos Status closed => feedback
2014-06-04 09:20 ddos Resolution unable to reproduce => reopened
2014-06-04 09:20 ddos Note Edited: 0001984 View Revisions
2014-06-04 09:31 muts Note Added: 0001985
2014-06-04 09:31 muts Summary pip install pyOpenSSL=0.13.1 => w3af not working (was pip install pyOpenSSL=0.13.1)
2014-06-04 09:41 muts Note Edited: 0001985 View Revisions
2014-06-04 09:52 muts Note Edited: 0001982 View Revisions
2014-06-04 09:56 muts Note Edited: 0001985 View Revisions
2014-06-04 15:09 muts Note Added: 0001995
2014-06-04 15:09 muts Status feedback => closed
2014-06-04 15:09 muts Resolution reopened => fixed
2014-06-04 15:09 muts Status closed => resolved