View Issue Details

IDProjectCategoryView StatusLast Update
0001654Kali Linux[All Projects] New Tool Requestspublic2017-07-08 18:15
Reporteri3visio Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0001654: Inclusion of new OSINT tool: usufy.py (GPLv3 username checker)
Descriptionusufy.py is a GPLv3 OSINT tool that checks the existence of a profile in a bunch of different platforms (by 2014/Aug/10: 150 different platforms).
Making use of a very easy-to-replicate approach, it analyses the messages displayed by most platforms when a user profile has not been found as the evidence of the existence or not the profile searched. Its inheritance system has been designed to allow an easy development of new wrappers and new ways of exporting the results to other tools, while its multiprocessing conception is intended to provide results quickly.

By the time of this report, the tool works with the following 150 platforms:
'About', 'Adtriboo', 'Anarchy101', 'Aporrealos', 'Backyardchickens', 'Badoo', 'Behance', 'Bitbucket', 'Bitcointalk', 'Bitly', 'Blackplanet', 'Bladna', 'Blip', 'Blogspot', 'Burbuja.info', 'Buzznet', 'Cafemom', 'Carbonmade', 'Care2', 'Connectingsingles', 'Couchsurfing', 'Dailymail', 'Dailymotion', 'Deviantart', 'Disqus', 'Doodle', 'Douban', 'Dribbble', 'Ebay', 'Echatta', 'ElMundo', 'Enfemenino', 'Epinions', 'Etsy', 'Facebook', 'Fanpop', 'Favstar', 'Fark', 'Flickr', 'Flixster', 'Foodspotting', 'Forobtc', 'Forocoches', 'Forosperu', 'Foursquare', 'Freebase', 'Friendfeed', 'Garage4hackers', 'Gather', 'Genspot', 'GetSatisfaction', 'Github', 'Gitorious', 'Gogobot', 'Goodreads', 'GooglePlus', 'Gsmspain', 'Hellboundhackers', 'Hi5', 'Identica', 'Imgur', 'Instagram', 'Instructables', 'Issuu', 'Ixgames', 'Jamiiforums', 'Kaboodle', 'Kali', 'Karmacracy', 'Kickstarter', 'Kinja', 'Klout', 'Kongregate', 'Kupika', 'Lastfm', 'Linkedin', 'Livejournal', 'Looki', 'Marca', 'Matchdoctor', 'Mediavida', 'Medium', 'Meneame', 'Metacafe', 'Migente', 'Myeloma', 'Myspace', 'Naver', 'Netlog', 'Netvibes', 'Occupywallst', 'Odnoklassniki', 'Pastebin', 'Pearltrees', 'Peerbackers', 'Photobucket', 'Pinterest', 'Plancast', 'Pokerstrategy', 'Pornhub', '500px', 'QQ', 'Rankia', 'Ratemypoo', 'Rebelmouse', 'Redtube', 'Researchgate', 'Scribd', 'Sencha', 'Slashdot', 'Slideshare', 'Soundcloud', 'Sourceforge', 'Storify', 'Stumbleupon', 'Spaniards', 'Spoj', 'Squidoo', 'Stuff', 'Steamcommunity', 'Streakgaming', 'Technorati', 'Theguardian', 'Thehoodup', 'Thestudentroom', 'Tradimo', 'Tripadvisor', 'Tumblr', 'Tuporno', 'Tvtag', 'Twicsy', 'Twitch', 'Twitpic', 'Twitter', 'Ukdebate', 'Unsystem', 'Ustream', 'Vimeo', 'Vk', 'Xanga', 'Xing', 'Xtube', 'Winamp', 'Wefollow', 'Wishlistr', 'Wordpress', 'Wykop', 'Youku', 'Youtube', 'Zabbix'.

Amongst the technical characteristics:
- Processing multiple nicknames.
- Input types: terminal or file
- Individual selection of platforms by type or name.
- Multiprocessing capabilities.
- Exports to .csv and .json files.
- Storage of the profiles recovered for further processing.
- Basic GUI for managing different profiles.
- Mechanized browser class.
- Forbidden characters control.
- Benchmarking.
- Thread control.
- Logging methods.
Steps To ReproduceInstallation development version:
wget https://github.com/i3visio/usufy/archive/master.zip
7z x master.zip
cd usufy-master
sudo python setup.py install

Testing the installation:
python -c "import usufy"

Running the program (from usufy-master folder):
cd usufy
- Showing help:
python usufy.py -h
- Basic search:
python usufy.py -n i3visio
- Basic search with 64 threads:
python usufy.py -n i3visio -T 64
- Basic search for two users generating a csv and json file:
python usufy.py -n i3visio usufy -e csv json
- Launching minimalist gui:
python usufy.py --gui
- Launching benchmark mode:
python usufy.py --benchmark
Additional InformationThere exist a v1.3.0b released in pypi.com and Github:
https://github.com/i3visio/usufy/releases
https://pypi.python.org/pypi/Usufy/v1.3.0b

Relationships

duplicate of 0003042 resolvedsbrun Add OSRFramework v6.0 - Tools for user profiling and online research 

Activities

i3visio

2014-08-09 22:59

reporter  

master.zip (201,760 bytes)

i3visio

2014-09-09 06:55

reporter  

usufy-master - v1.3.0b-2.zip (307,331 bytes)

Issue History

Date Modified Username Field Change
2014-08-09 22:59 i3visio New Issue
2014-08-09 22:59 i3visio File Added: master.zip
2014-09-09 06:55 i3visio File Added: usufy-master - v1.3.0b-2.zip
2017-06-22 14:18 g0tmi1k Relationship added duplicate of 0003042
2017-07-08 18:15 rhertzog Assigned To => rhertzog
2017-07-08 18:15 rhertzog Status new => closed
2017-07-08 18:15 rhertzog Resolution open => duplicate