View Issue Details

IDProjectCategoryView StatusLast Update
0001844Kali Linux[All Projects] Tool Upgrade Requestpublic2015-09-03 13:08
Reporterbthaler Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2.0 
Summary0001844: Upgrade iptables to 1.4.21
Descriptioniptables version inherited from debian upstream is currently 1.4.14

this version lacks support for IPv6 NAT66 targets supported by 3.7++ kernels. iptables supports these since 1.4.17, however upgrade to 1.4.21 is recommended as a lot of documentation of IPv6 specific targets and bugfixes are included in most recent version.

IPv6 may be more and more interesting in security testing and research, ability to SNAT/DNAT/REDIRECT packets may be crucial for some use cases. A version of iptables in Kali supporting these will be beneficial.

Activities

rhertzog

2015-09-03 13:08

administrator   ~0003921

Kali 2 has version 1.4.21.

Issue History

Date Modified Username Field Change
2014-10-26 22:38 bthaler New Issue
2014-11-21 20:03 haider Issue cloned: 0001889
2015-09-03 13:08 rhertzog Note Added: 0003921
2015-09-03 13:08 rhertzog Status new => resolved
2015-09-03 13:08 rhertzog Fixed in Version => 2.0
2015-09-03 13:08 rhertzog Resolution open => fixed
2015-09-03 13:08 rhertzog Assigned To => rhertzog
2021-05-31 13:37 rhertzog Category Tool Upgrade => Tool Upgrade Request