View Issue Details

IDProjectCategoryView StatusLast Update
0001856Kali Linux[All Projects] Kali Package Bugpublic2014-12-02 13:31
Reportershadowtech Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.9 
Target VersionFixed in Version1.1.0 
Summary0001856: on a freash install with 1.0.9a cant not install kali-linux-all
DescriptionTrying to install kali-linux-all and getting errors.


 
Steps To Reproducefresh install
apt-get update && apt-get upgrade && apt-get dist-upgrade
reboot


root@kali01:~# apt-get install kali-linux-all
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kali-linux-all : Depends: kali-linux-forensic but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

root@kali01:~# apt-get install kali-linux-forensic
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kali-linux-forensic : Depends: cuckoo but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


root@kali01:~# apt-get install cuckoo
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuckoo : Depends: python-pydeep but it is not going to be installed
          Recommends: python-django (>= 1.5) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


root@kali01:~# apt-get install python-pydeep
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-pydeep : Depends: libfuzzy2 (>= 2.6) but it is not installable
E: Unable to correct problems, you have held broken packages.


root@kali01:~# apt-get install libfuzzy2
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libfuzzy2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libfuzzy2' has no installation candidate
root@kali01:~#

Additional InformationTesting on a ESXi 5.5

in IRC channel as shadowtech

Activities

rhertzog

2014-11-03 09:51

administrator   ~0002683

The package got removed from wheezy due to license problems:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=764937

It seems to link GPL code with code not compatible with the GPL and is thus undistributale. Thus it might not be a good idea to reintroduce it in Kali... we should look for other solutions. I don't know hom important that library is for cuckoo but maybe we can drop the dependency for a start and reach out to upstream developers about it.

fiction

2014-12-01 19:30

reporter   ~0002840

I also have this issue... with kali-linux-sdr, kali-linux-all

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kali-linux-sdr : Depends: gqrx but it is not going to be installed
                  Depends: libgnuradio-osmosdr-apps but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sbrun

2014-12-02 13:31

manager   ~0002845

a fixed package ssdeep has been made available in jessie. I imported it in kali.
cuckoo is now again installable

Issue History

Date Modified Username Field Change
2014-11-02 21:47 shadowtech New Issue
2014-11-03 09:51 rhertzog Note Added: 0002683
2014-11-21 20:03 haider Issue cloned: 0001894
2014-12-01 19:30 fiction Note Added: 0002840
2014-12-02 13:31 sbrun Note Added: 0002845
2014-12-02 13:31 sbrun Status new => resolved
2014-12-02 13:31 sbrun Resolution open => fixed
2014-12-02 13:31 sbrun Fixed in Version => 1.1.0