View Issue Details

IDProjectCategoryView StatusLast Update
0001871Kali Linux[All Projects] Kali Package Bugpublic2016-03-11 15:42
Reporterrhertzog Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target Version2.0Fixed in Version2016.2 
Summary0001871: Find a way to disable most services by default with systemd
DescriptionKali forks update-rc.d to disable most services that depend on $network to avoid having services be accessible without any admin configuration.

Kali Rolling switched to systemd and the hack in update-rc.d is now mostly useless. We must find a new solution for this.

Activities

rhertzog

2014-12-08 14:25

administrator   ~0002860

It looks like that the proper answer is using a "preset" file: http://freedesktop.org/wiki/Software/systemd/Preset/

This answers at least how to not enable services by default. But it doesn't answer how to not start any service in "forensic" mode. This is probably implemented with a different "target" at boot time.

rhertzog

2014-12-09 09:10

administrator   ~0002861

Unfortunately, it looks like we can't use Preset file in Debian currently. I just filed a bug about this: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=772555

rhertzog

2015-03-25 06:05

administrator   ~0003185

It looks like most of the services are still properly disabled thanks to some systemd/update-rc.d integration. But there are corner cases when the packages ships a .service file that does not have the same name as the init script.

I just filed http://bugs.debian.org/781155 on openbsd-inetd for example. And also the update-rc.d integration with systemd is somewhat problematic: http://bugs.debian.org/746580

jaromil

2015-07-22 10:30

reporter   ~0003558

Hi there and apologies for slight off-topic, just mentioning:

In case you do experience too many problems with the systemd switch of Debian, we have arms open over at Devuan with a beta release approaching and a complete CI that is building packages for all original targets, see http://devuan.org

Even just an experimental branch of Kali 2.0 based on Devuan would be easy to do and may provide a better experience for both users and developers.

rhertzog

2015-07-22 12:29

administrator   ~0003559

Jaromil, in fact the switch has been rather smooth for us and we look forward to taking advantages of systemd's feature set!

rhertzog

2016-03-08 10:35

administrator   ~0004826

This issue should be fixed with init-system-helpers_1.28+kali3.dsc and base-files 2016.2.0.

base-files provides systemctl preset files and init-system-helpers has been modified so that "deb-systemd-helper enable" calls "systemctl preset" instead of doing the work itself.

Issue History

Date Modified Username Field Change
2014-11-17 14:57 rhertzog New Issue
2014-11-17 15:26 rhertzog Product Version => kali-dev
2014-11-17 15:26 rhertzog Summary Find a way to disable most services by default => Find a way to disable most services by default with systemd
2014-11-21 20:03 haider Issue cloned: 0001908
2014-12-08 14:25 rhertzog Note Added: 0002860
2014-12-09 09:10 rhertzog Note Added: 0002861
2015-03-25 06:05 rhertzog Note Added: 0003185
2015-03-26 10:44 rhertzog Assigned To => rhertzog
2015-03-26 10:44 rhertzog Status new => assigned
2015-07-22 10:30 jaromil Note Added: 0003558
2015-07-22 12:29 rhertzog Note Added: 0003559
2015-07-23 18:50 rhertzog Severity major => minor
2016-03-08 10:35 rhertzog Note Added: 0004826
2016-03-11 15:42 rhertzog Status assigned => resolved
2016-03-11 15:42 rhertzog Fixed in Version => 2016.2
2016-03-11 15:42 rhertzog Resolution open => fixed
2016-03-17 06:25 newhack Issue cloned: 0003156
2016-03-17 06:26 newhack Issue cloned: 0003161