2017-09-25 18:39 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002396Kali Linux[All Projects] Kali Websites & Docspublic2017-08-24 14:56
Reporterredfast 
Assigned Tomuts 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version1.1.0 
Target VersionFixed in Version2017.2 
Summary0002396: docs.kali.org needs to be updated with new instructions for building a custom live iso
DescriptionWhen I tried to customise my kali image, it would only build a 450M image that booted to a commandprompt: no tools were installed, nor a desktop. I didn't change anything, except from adding "keyboard-layouts=be" in my auto/config.
Steps To ReproduceThese steps came from http://docs.kali.org/development/live-build-a-custom-kali-iso

apt-get install git live-build cdebootstrap kali-archive-keyring
git clone git://git.kali.org/live-build-config.git
cd live-build-config
lb config
lb build
Additional InformationIt worked a few months ago, but I had to delete my live-build directory, and now it stopped working. I think this is because of (https://www.kali.org/news/kali-linux-1-1-0-released/) "Our ISO build systems are now running off live-build 4.x."
Attached Files

-Relationships
+Relationships

-Notes

~0003482

rhertzog (administrator)

The docs needs to be updated. In general, you should always use "./build.sh --verbose" to build the image. It will merge files from kali-config/* into config and then call live-build appropriately.

Bonus point, you have a few variants ready to use for example "./build.sh --variant kde" ...

~0007114

muts (administrator)

Docs fixed a while back.
+Notes

-Issue History
Date Modified Username Field Change
2015-07-07 10:00 redfast New Issue
2015-07-07 16:14 rhertzog Note Added: 0003482
2015-07-07 16:16 rhertzog Assigned To => muts
2015-07-07 16:16 rhertzog Status new => assigned
2015-07-07 16:16 rhertzog Summary When building an image with live-build, it doesn't look at the package-list => docs.kali.org needs to be updated with new instructions for building a custom live iso
2016-08-26 08:35 rhertzog Category General Bug => Kali Websites & Docs
2016-09-16 14:54 fox Issue cloned: 0003580
2017-08-24 14:56 muts Status assigned => closed
2017-08-24 14:56 muts Resolution open => fixed
2017-08-24 14:56 muts Fixed in Version => 2017.2
2017-08-24 14:56 muts Note Added: 0007114
2017-08-24 14:56 muts Status closed => resolved
+Issue History