View Issue Details

IDProjectCategoryView StatusLast Update
0000245Kali Linux[All Projects] General Bugpublic2013-04-11 22:36
Reportermustu Assigned Todookie  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000245: Screen Lock Doesn't Work
DescriptionWhen I try to lock screen using Ctrl+Alt+L or using the Gnome menu it doesn't lock the screen. Upon pressing Ctrl+Alt+L screen goes blank but on pressing any key it returns to desktop and doesn't show the lock screen.
Steps To ReproducePress Ctrl+Alt+L

Activities

mustu

2013-04-05 19:10

reporter   ~0000331

Last edited: 2013-04-05 19:10

View 2 revisions

It's running on HP ProBook 4530s and I'm using the root user.

mustu

2013-04-05 19:36

reporter   ~0000332

I've tried it in a standard user and it's working. However it doesn't work when root user is logged in.

aru

2013-04-10 08:51

reporter   ~0000352

User system_crash wrote in the forum, that the root user is blocked in the source code of "gnome-screensaver". that might be useful for a normal debian-user but for kali, where everybody works as root that's no acceptable. If I leave my pentest-laptop for some hours in the data-center to perform a scan, it has to be locked.

system_crash

2013-04-10 14:06

reporter   ~0000353

I've posted the solution on forum, hope it works fine for you too.

dookie

2013-04-10 17:34

administrator   ~0000354

This looks like an easy fix and it's worth forking the Debian package to get it working.

system_crash

2013-04-10 17:43

reporter   ~0000355

Should I upload it or?

dookie

2013-04-10 17:45

administrator   ~0000356

I will fork it and fixed in on our end hopefully at some time today.

Thanks.

system_crash

2013-04-10 17:57

reporter   ~0000357

Alright, no problem.

dookie

2013-04-11 22:36

administrator   ~0000359

Patched in gnome-screensaver_3.4.1-1kali0. It should be in the repos soon.

Thanks.

Issue History

Date Modified Username Field Change
2013-04-05 18:46 mustu New Issue
2013-04-05 19:10 mustu Note Added: 0000331
2013-04-05 19:10 mustu Note Edited: 0000331 View Revisions
2013-04-05 19:36 mustu Note Added: 0000332
2013-04-10 08:51 aru Note Added: 0000352
2013-04-10 14:06 system_crash Note Added: 0000353
2013-04-10 17:33 dookie Assigned To => dookie
2013-04-10 17:33 dookie Status new => assigned
2013-04-10 17:34 dookie Note Added: 0000354
2013-04-10 17:43 system_crash Note Added: 0000355
2013-04-10 17:45 dookie Note Added: 0000356
2013-04-10 17:57 system_crash Note Added: 0000357
2013-04-11 22:36 dookie Note Added: 0000359
2013-04-11 22:36 dookie Status assigned => closed
2013-04-11 22:36 dookie Resolution open => fixed