View Issue Details

IDProjectCategoryView StatusLast Update
0002542Kali Linux[All Projects] Kali Package Bugpublic2015-08-16 11:18
Reporteraltj Assigned Torhertzog  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version 
Summary0002542: armhf apt repo's Packages.gz references non-existent package versions
DescriptionIt appears that the Packages list isn't being properly updated.

I'm trying to install kali-linux-top10 for armhf but it fails with this error (even after an apt-get update):

After this operation, 789 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Err http://http.kali.org/kali/ sana/main kali-linux armhf 1.67
  404 Not Found
Err http://http.kali.org/kali/ sana/main metasploit-common armhf 1.0.2-0kali0+b1
  404 Not Found
Err http://http.kali.org/kali/ sana/main metasploit-framework armhf 4.11.3-2015063001-1kali0+b1
  404 Not Found
Err http://http.kali.org/kali/ sana/main kali-linux-top10 armhf 1.67
  404 Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/k/kali-meta/kali-linux_1.67_armhf.deb 404 Not Found

E: Failed to fetch http://http.kali.org/kali/pool/main/m/metasploit-common/metasploit-common_1.0.2-0kali0+b1_armhf.deb 404 Not Found

E: Failed to fetch http://http.kali.org/kali/pool/main/m/metasploit-framework/metasploit-framework_4.11.3-2015063001-1kali0+b1_armhf.deb 404 Not Found

E: Failed to fetch http://http.kali.org/kali/pool/main/k/kali-meta/kali-linux-top10_1.67_armhf.deb 404 Not Found

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Steps To ReproduceOn armhf run:
apt-get update
apt-get install kali-linux-top10
Additional InformationLooking at http://http.kali.org/dists/sana/main/binary-armhf/Packages.gz it lists version 1.67 for kali-linux-top10 but that version doesn't exist.
In looking at the files here http://http.kali.org/kali/pool/main/k/kali-meta/ I don't see files for version 1.67, but do see them for 1.55.25, 2.41 and 3.1

From the other messages in the error output, it looks like kali-linux-top10 isn't the only package with the problem.

Activities

rhertzog

2015-08-15 21:06

administrator   ~0003771

Please tell us what mirror you are redirected to when you try to download those files.

For example paste the output of "curl -sI http://http.kali.org/README".

altj

2015-08-15 22:42

reporter   ~0003776

$ curl -sI http://http.kali.org/README
HTTP/1.1 302 Found
Date: Sat, 15 Aug 2015 22:41:22 GMT
Server: Apache/2.2.22 (Debian)
X-MirrorBrain-Mirror: mirror2.gaw.solutions
X-MirrorBrain-Realm: country
Link: <http://http.kali.org/README.meta4>; rel=describedby; type="application/metalink4+xml"
Link: <http://mirror2.gaw.solutions/kali/README>; rel=duplicate; pri=1; geo=us
Link: <http://mirror1.gaw.solutions/kali/README>; rel=duplicate; pri=2; geo=us
Link: <http://mirror3.gaw.solutions/kali/README>; rel=duplicate; pri=3; geo=us
Link: <http://kali.localmsp.org/kali/README>; rel=duplicate; pri=4; geo=us
Link: <http://archive-7.kali.org/kali/README>; rel=duplicate; pri=5; geo=us
Location: http://mirror2.gaw.solutions/kali/README
Vary: Accept-Encoding
Content-Type: text/html; charset=iso-8859-1

altj

2015-08-15 23:43

reporter   ~0003777

Last edited: 2015-08-15 23:43

View 2 revisions

Ah yes, it does look like that mirror is out of date. The timestamp on the Packages file is July 4 of this year.

rhertzog

2015-08-16 09:00

administrator   ~0003786

Thanks, I dropped the problematic mirrors from rotation until they can be fixed.

Issue History

Date Modified Username Field Change
2015-08-15 20:03 altj New Issue
2015-08-15 21:06 rhertzog Note Added: 0003771
2015-08-15 21:06 rhertzog Assigned To => rhertzog
2015-08-15 21:06 rhertzog Status new => feedback
2015-08-15 22:42 altj Note Added: 0003776
2015-08-15 22:42 altj Status feedback => assigned
2015-08-15 23:43 altj Note Added: 0003777
2015-08-15 23:43 altj Note Edited: 0003777 View Revisions
2015-08-16 09:00 rhertzog Note Added: 0003786
2015-08-16 11:18 rhertzog Status assigned => resolved
2015-08-16 11:18 rhertzog Resolution open => fixed